WordPress.org

Ready to get started?Download WordPress

Forums

Amen
[resolved] Help Please - After updating today (7 posts)

  1. josephmiddleton
    Member
    Posted 1 year ago #

    After updating today, My admin screen went blank and keep on getting a 500 error for admin.

    below is what firefox is displaying for error

    Timestamp: 3/6/2013 10:33:28 AM
    Error: The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.
    Source File: http://joseph.heavenboundministry.com/jjblog/wp-admin/
    Line: 0

    Internet explorer displays

    Most likely causes:
    •The website is under maintenance.
    •The website has a programming error.

    error log in admin dir displays

    [06-Mar-2013 17:28:22 UTC] WordPress database error Multiple primary key defined for query ALTER TABLE wp_amen_requests ADD PRIMARY KEY id (id) made by require_once('wp-admin/admin.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), call_user_func_array, amen_update_check, amen_install, dbDelta
    [06-Mar-2013 17:28:22 UTC] WordPress database error Multiple primary key defined for query ALTER TABLE wp_amen_prayers ADD PRIMARY KEY id (id) made by require_once('wp-admin/admin.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), call_user_func_array, amen_update_check, amen_install, dbDelta
    [06-Mar-2013 17:28:22 UTC] WordPress database error Duplicate key name 'prayer_id' for query ALTER TABLE wp_amen_prayers ADD UNIQUE KEY prayer_id (request_id, session_id) made by require_once('wp-admin/admin.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), call_user_func_array, amen_update_check, amen_install, dbDelta
    [06-Mar-2013 17:28:23 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:28:27 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:28:32 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:28:38 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:28:46 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:29:06 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:29:24 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:29:57 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:30:25 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:32:16 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:32:23 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:33:30 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:38:40 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 17:38:46 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 18:04:43 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43
    [06-Mar-2013 18:05:08 UTC] PHP Fatal error:  Class 'ToppaFunctions' not found in serverdirs/wp-content/plugins/extensible-html-editor-buttons/lib/ButtonableSettings.php on line 43

    Help Please. . .

    http://wordpress.org/extend/plugins/amen/

  2. josephmiddleton
    Member
    Posted 1 year ago #

    After renaming the 2 updates that mattered, one was not active but still updated, everything ran fine. Renamed the Amen folder and everything is still running fine.

    Sorry for the confusion but was desperate and not too techy was a bit desperate to fix it...

  3. UaMV
    Member
    Plugin Author

    Posted 1 year ago #

    Weird. Sorry for that trouble. i'll have to look into it. Hope it has not been encountered by too many others. And glad you got it sorted out!

  4. josephmiddleton
    Member
    Posted 1 year ago #

    Ahhh, yours was npot the problem-tried to say that. It worked fine I just had three updates today and yours was one of them. But I renamed all 3 dirs and all was fine. Then I renamed yours back to Amen and everything was still fine so it took yours off the problem list it was fine. But the author of the one that caused troubles fixed it today quickly enough. Sorry for the bother

  5. UaMV
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, wonderful! Thanks for the update. I'll mark as resolved. Still must get to your other issue at some point.

  6. joesbunker
    Member
    Posted 1 year ago #

    After last two updates, the plugin is broken. I get a few lines of script at the top of my admin page, and I had to deactivate to get my sites to work (I used it on two separate sites). I tried uninstall and re-install, but same issue. was working fine until the updates over the past 2 days.

  7. UaMV
    Member
    Plugin Author

    Posted 1 year ago #

    @joesbunker: Do you remember what the script said? i know the likely culprit and will take a look at this. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.