WordPress.org

Ready to get started?Download WordPress

Forums

ColorWay
Adding buttons (24 posts)

  1. fypp
    Member
    Posted 1 year ago #

    Please someone help me.. I am using the colorway theme and have noticed since adding the two buttons on the right top of each page that my page views poorly on mobile devices. How do i make the buttons appear correctly on a mobile device.
    Also, is it true that I will lose all my work if I were to upgrade to another inkthemes template? I was considering The Regal but don't want to lose all of my work, especially blog posting. Thanks. the url is:
    foryourprivilegedpets.com

    All the best, D

    http://wordpress.org/extend/themes/colorway/

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    How do i make the buttons appear correctly on a mobile device.

    Sorry, can you define your expectations of the buttons displaying correctly?

  3. fypp
    Member
    Posted 1 year ago #

    sure, on my android device, the green buttons take over the top of the screen. Do you have a mobile device you can view it on to see what I mean?

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    I can see what you mean, but you haven't expressed how you would expect the buttons to appear.

  5. fypp
    Member
    Posted 1 year ago #

    awww, gotcha! I would like them to appear under the logo and before the page navigational menu. Both aligned, one on top of the other? doesn't matter which one on top... does that make sense? sorry this is all new to me:)

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    Do you have a place in the dashboard to hold your CSS modifications, other than modifying the theme's files?

  7. Andrew
    Forum Moderator
    Posted 1 year ago #

    You need to add this CSS;

    @media only screen and (max-device-width: 480px) {
    
     a.maxbutton-1,
     a.maxbutton-6 {
      position: initial !important;
      display: block;
      margin: 0 auto;
      width: 300px;
     }
    
     a.maxbutton-1 {
      margin-top: 20px !important;
     }
    
    }

    You may want to avoid using !important on all of your styles. It's unnecessary.

  8. fypp
    Member
    Posted 1 year ago #

    yes i do.. I have updated the theme quite a bit that way:)

  9. fypp
    Member
    Posted 1 year ago #

    ok I did what you said and entered the code, but on my phone it is still off. perhaps it is my settings on my mobile device. could you check on yours and tell me how it looks. thanks so much for your help! I have been pulling out my hair trying to figure this out.

  10. Andrew
    Forum Moderator
    Posted 1 year ago #

    How are you adding the CSS, how is it within the <body> section?

  11. fypp
    Member
    Posted 1 year ago #

    I thought I was doing it right by adding it to the css style sheet within the theme options. Now I am getting a parse error when I try to log in. the error is

    Parse error: syntax error, unexpected ',' in /home/content/97/10273797/html/wp-content/themes/colorway/functions/options-medialibrary-uploader.php on line 285

    I have no clue but am going to contact godaddy and see if they know how to fix this:) I will let you know once it is fixed so we can proceed getting these buttons fixed. thanks for your help with this...

  12. fypp
    Member
    Posted 1 year ago #

    I fixed my little problem with the parse error. All is good now on to the buttons being responsive. Is the code suppose to be in the css stylesheet or somewhere else? thanks again for your help..

  13. fypp
    Member
    Posted 1 year ago #

    Hey Andrew, still having issues with this. I am placing the code in the css stylesheet. Please let me know what I am doing wrong. Thanks!

  14. Andrew
    Forum Moderator
    Posted 1 year ago #

    There is some CSS within the <body> element with !important styles. That will override your stylesheet.

    Why are there styles in the <body> section?

  15. fypp
    Member
    Posted 1 year ago #

    I am completely confused... I placed the code under
    dashboard>appearance>editcss>

    Are you saying that i need to take out all of the !important coding in order for the code you gave me to work? sorry, very new to this!

  16. Andrew
    Forum Moderator
    Posted 1 year ago #

    I'd first focus on the method you're using to add CSS.
    Edit CSS, is that an option given by the Jetpack plugin?

  17. fypp
    Member
    Posted 1 year ago #

    I see what you are saying. I am using the css editor in the colorway theme. I took out all of the !important from there and added the code you gave me, also taking out the !important. It is still not working properly. help!

  18. Andrew
    Forum Moderator
    Posted 1 year ago #

    Your theme does not behave as it should. It is entering a lot of stuff that should be in the <head> section but are in the <body>. Your CSS is still in the <body>.

    That is my conclusion as to why your CSS Media Queries are not working.

    I'd usually recommend reinstalling the theme, but it sounds like you made changes to the theme's files, so I don't know what to recommend.

  19. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  20. fypp
    Member
    Posted 1 year ago #

    Thanks for your honest opinion Andrew and help, I appreciate it.
    WPyogi, how do I find the errors to fix them?

  21. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    The second link above explains some - there isn't an easy way - you need to use the validator results to look at the generated code from the page you've validated - use View Source in your browser to see the code. Then you have to track down where that code is coming from - it looks like those errors are in the header.php file - if you have changed that file, that's probably why, but some plugins can do that and it's possible the theme has code errors.

    I mentioned this because of what Andrew said about the code being messed up in your header section.

    If you've changed the header.php file, you could try comparing your file with a new copy (download the theme to your local computer).

    And really, you should not modify theme files...but use a Child Theme instead.

  22. fypp
    Member
    Posted 1 year ago #

    Thanks for your detailed reply, WPyogi. I am going to figure out how to fix these errors you pointed out. In the meantime, is there a way to make my green buttons on the top of each page "not" viewable on a mobile device, just until I can figure out what to do with this?
    I may just have to reinstall the theme.

  23. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    See if adding this to your custom CSS will work:

    @media (max-width: 800px) {
      a.maxbutton-1, .maxbutton-6-container {
         display: none !important;
    }
    
    }
  24. fypp
    Member
    Posted 1 year ago #

    YOU My friend are a miracle worker! thank you so much!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags