WordPress.org

Ready to get started?Download WordPress

Forums

Help please!!!!! (8 posts)

  1. mulligan
    Member
    Posted 9 years ago #

    I've upgraded to WP 1.5 from 1.2. Everything worked great. I set up my old template the way Podz said to do it. When I activate my old template I get my site with no posts and this message "Sorry, no posts matched your criteria."

    When I activate the default theme, my posts are there. When I activate the classic theme, my posts are there. Have I missed a step somewhere along the line?

    My site is here: http://www.cantkeepquiet.com/

    I don't like the classic theme. The default theme is okay. What I really want, though, is my theme. Please, please, please, help me.

  2. Anonymous
    Unregistered
    Posted 9 years ago #

    It's possible that whatever loop method you were using before no longer works with WP 1.5. Please make a copy of your index.php theme file, rename it to index.phps (or index.txt), and post a link here so that it may be examined.

  3. mulligan
    Member
    Posted 9 years ago #

    I did what you suggested. You can find the copy of the index file here:

    http://www.cantkeepquiet.com/wp-content/themes/mytheme/index.phps

    BTW, doing that has caused a 403 error on my site. Grrrr!

  4. Anonymous
    Unregistered
    Posted 9 years ago #

    Looks like your custom loop is messing it up. Change:
    <?php if ($hcp_posts) : foreach ($hcp_posts as $post) : start_wp(); ?>
    to
    <?php if ($posts) : foreach ($posts as $post) : start_wp(); ?>

  5. mulligan
    Member
    Posted 9 years ago #

    I don't know if that worked or not. Even though I've deleted the index.phps file I still get the 403 Forbidden message when I try to go to my blog. I've tried reloading, and clearing the cache. Now what!?!?

  6. Cypher
    Member
    Posted 9 years ago #

    Delete your .htaccess file if you had one and see if things get better.

    Regards

  7. ceo
    Member
    Posted 9 years ago #

    Hmm, I can't even access your site, so I don't know. Did you try deleting your htaccess? Or your theme and loading the default and then reuploading and selecting your theme again?

    EDIT: Hehe, whoops Cypher beat me. Oh, well.

  8. mulligan
    Member
    Posted 9 years ago #

    I have deleted the htaccess file 5 times now. I have downloaded my theme to my computer and deleted it. I have cleared my cache. I have closed my browser and restarted it. I have turned off my computer and restarted it. Basically, I've done all that I can think of. Granted, I'm no expert when it comes to this.

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.