WordPress.org

Ready to get started?Download WordPress

Forums

HELP - Permalink structure creates problem for Slideshow (3 posts)

  1. damian5
    Member
    Posted 6 years ago #

    Hello!

    I am trying to integrate a Frontpage Slideshow from Joomlaworks on to my blog. I put the code in the main index template just above the posts:

    <?php include("fpss/fpss.php"); ?>

    It works fine on the main page, but when I click on previous page or if I add the code on the single post template, then it looks all out of wack. It seems like it cannot recognize the player, but the links appear.

    You can view a picture of what it looks like here.

    It has something to do with the permalinks structure I think because when I tried to install in on a blog that still had the default permalink, I didn't have any problems.

    The .htaccess file rewrite is probably what is causing the problem. I don't know much about it and what exactly could be causing the problem. Does the rewrite rules affect Javascripts.

    Can anyone help?

    Thank you.

  2. theapparatus
    Member
    Posted 6 years ago #

    Try using a full URL and not just the file name. Please remember that when you click through into your blog, teh url changes to reflect where you are within your blog.

  3. damian5
    Member
    Posted 6 years ago #

    Yeah, I tried that but if I do that then I get errors and the slideshow doesn't even show anymore.

    Plus I don't think it's a problem with finding the file. It's finding the file ok and the links and everything, but for some reason it cannot put the player together.

    Any other ideas?

    Like I said I think it has to do with something getting in the way of the Javascript.

Topic Closed

This topic has been closed to new replies.

About this Topic