WordPress.org

Ready to get started?Download WordPress

Forums

Help needed in installing WordPress on Virtualmin (19 posts)

  1. sameermanas
    Member
    Posted 2 years ago #

    Hello,

    I got a VPS with CentOS 5.7 on it. I've asked the hosting people to give me VirtualMin as it is free.

    I tried several ways to install WordPress on it but i can't get the work done. I came across a lot of tutorials on the net and tried them but it isn't helping !

    Finally i am getting this message when i try to install WP
    "Your PHP installation appears to be missing the MySQL extension which is required by WordPress."

    But i have the MySQL installed. Can anyone help me out with Installing WP on VirtualMin/Webmin

  2. ChristiNi
    Member
    Posted 2 years ago #

  3. sameermanas
    Member
    Posted 2 years ago #

    Hi ChristiNi,

    Those threads are helpful to me. I tried some steps from them but now problem is redirected to PHP

    I am getting PHP missing on the install.php even when it is installed on the VPS

    Can you suggest any remedy on that

    These are the websites that we are trying to get installed

    http://www.gensparkmedia.com/wp-admin/install.php
    http://www.choicebasket.com/wp-admin/install.php

    Both give me the same error !

  4. frankietalks
    Member
    Posted 2 years ago #

    kind of bumping into similar problem... Error:PHP is not running

    See if someone may help. Thanks a lot.

  5. Tim S
    Member
    Posted 2 years ago #

    Hi sameermanas,

    It appears PHP is not configured correctly to execute the PHP files. You may want to contact the hosting provider to see if they can help you.

  6. sameermanas
    Member
    Posted 2 years ago #

    Hi Tim,

    I tried contacting them numerous times but they aren't so good at responding to customer problems.

    The blogs are to be installed on a VPS with CentOS on it. I tried restarting the apache server but that didn't help me either !

    I don't understand what steps i need to take further.

  7. ChristiNi
    Member
    Posted 2 years ago #

    Hi sameermanas,

    Can you try creating and uploading a phpinfo.php page? If you're not familiar with that, here's the instructions:

    http://www.webhostinghub.com/support/website/how-to/viewing-php-settings-with-phpinfo-page

    If the phpinfo page loads, then PHP is at least being executed by your server.

    Let me know what happens with the phpinfo page.

  8. sameermanas
    Member
    Posted 2 years ago #

    Hi ChristiNi,

    I tried the tutorial and created a file but it is just displaying the content of the file as <? phpinfo(); ?>

    Also all the files in the WordPress directory are showing up with the content.

    I tried 755 on all directories and 644 on all files but still i get plain text when i go for

    http://www.gensparkmedia.com/wp-admin/install.php

    here is the file i made with phpinfo

    http://www.gensparkmedia.com/phpinfo.php

    What does it indicate ? PHP running or stopped ?

  9. ClaytonJames
    Member
    Posted 2 years ago #

    @sameermanas

    From a console, or if you are using webmin, open the interface; Menu > Others > Command shell, and Execute command: rpm -qa | grep php

    What is the response?

  10. sameermanas
    Member
    Posted 2 years ago #

    Hi Clayton,

    Here is the out put and i use Webmin

    wbm-php-pear-1.5-1
    php-xml-5.3.8-2.el5.art
    php-mcrypt-5.3.8-2.el5.art
    php-cli-5.3.8-2.el5.art
    php-gd-5.3.8-2.el5.art
    php-pecl-memcache-3.0.6-1.el5.art
    php-pdo-5.3.8-2.el5.art
    php-pdo-5.3.8-2.el5.art
    php-gd-5.3.8-2.el5.art
    php-xml-5.3.8-2.el5.art
    php-5.3.8-2.el5.art
    php-mysql-5.3.8-2.el5.art
    php-common-5.3.8-2.el5.art
    php-common-5.3.8-2.el5.art
    php-pear-1.7.2-2.el5.art
    php-mcrypt-5.3.8-2.el5.art
    php-5.3.8-2.el5.art
    php-mysql-5.3.8-2.el5.art
  11. ChristiNi
    Member
    Posted 2 years ago #

    Hello again ClaytonJames,

    I'm sorry you're still dealing with this issue. One last thing you can try is checking your document root for each domain for an .htaccess file. I you do have an .htaccess file for one or both domains, try renaming the .htaccess file to disable it. If your issue is still unresolved, your host really should be looking into this for you. It could be as simple as PHP not being added to your server's configuration file, but this is something your host really should have set up for you.

    Good luck and hope this helps!

  12. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    @ChristiNi: <*cough*> Clayton is a forum regular & something of an expert on server-related issues.<*cough*>

  13. ChristiNi
    Member
    Posted 2 years ago #

    So sorry! I addressed my last post to the wrong person, that was intended for sameermanas. Thank you for pointing that out esmi. Please pardon my mistalke Clayton!

  14. ClaytonJames
    Member
    Posted 2 years ago #

    @ChristiNi

    No problem!

    @esmi

    In reality, I'm just a "let's break all the things!" kind of guy. But I have fun trying. :-)

    @sameermanas

    Are those php53 packages from the Atomic repo? I've never used them myself, (I'm sticking with php 5.2.10 from the testing repo for the time being) so I don't have any point of reference for possible issues if they replace core packages, but I don't think I see anything telling in the output.

    Take a look inside of /etc/httpd/conf.d/php.conf

    ...are these lines all (present and) uncommented?

    LoadModule php5_module modules/libphp5.so
    
    AddHandler php5-script .php
    AddType text/html .php
    
    DirectoryIndex index.php
  15. sameermanas
    Member
    Posted 2 years ago #

    Hi Clayton,

    Those lines are all commented and also there exist another php.conf.rpmsave

    I came across a CentOS forum where i came to know that Atomic repo would be updating things by itself and everything would be automated. So i added that to the rep's. Do you think that is causing the issue ??

    Here is the content of the php.conf

    #
    # PHP is an HTML-embedded scripting language which attempts to make it
    # easy for developers to write dynamically generated webpages.
    #
    <IfModule prefork.c>
      LoadModule php5_module modules/libphp5.so
    </IfModule>
    <IfModule worker.c>
      LoadModule php5_module modules/libphp5-zts.so
    </IfModule>
    
    #
    # Cause the PHP interpreter to handle files with a .php extension.
    #
    AddHandler php5-script .php
    AddType text/html .php
    
    #
    # Add index.php to the list of files that will be served as directory
    # indexes.
    #
    DirectoryIndex index.php
    
    #
    # Uncomment the following line to allow PHP to pretty-print .phps
    # files as PHP source code:
    #
    #AddType application/x-httpd-php-source .phps

    Is it better to remove the comments or anything i should change ?
    If anyone can help me out i wouldn't mind giving my credentials to the VPS.

  16. ClaytonJames
    Member
    Posted 2 years ago #

    @sameermanas, Update:

    Well, I must say you certainly piqued my curiosity. Just for giggles, I loaded a fresh snapshot of 5.7 with the default httpd, MySQL (5.0) and PHP (5.1) configurations, and then installed virtualmin/webmin. I plopped a phpinfo file in the /html directory and it worked as expected. Next I activated the Atomic repo and ran a yum upgrade. This bumped my versions of MySQL and PHP to 5.5.18 and 5.3.8 respectively. I think this is probably what has been done on your server as well. I did a quick "service httpd restart" and then rechecked the phpinfo file. Still working as expected. The output of "rpm -qa | grep php" on my server is now almost identical to yours, with the exception of having no duplicate entries. I honestly don't know if that is a significant clue or not.

    I think at this point, if everything in /etc/httpd/conf.d/php.conf looks okay, you may want to put in a service call to your host as ChristiNi suggested. As slow as that might seem to be, they might be able to quickly point you to a solution. I'm sorry I couldn't duplicate the issue and offer a solution, but I had fun trying!

    [edit] your php.conf is identical to mine.

  17. sameermanas
    Member
    Posted 2 years ago #

    @ Clayton,

    Thanks for the help. I opened a ticket 5 days back but still they are lagging the issue and aren't responding. Maybe i'll have to wait for a few more days for this to be resolved.

    Thanks for your time :)

  18. ClaytonJames
    Member
    Posted 2 years ago #

    Wow, I guess they really are a little behind. You're very welcome, and I wish you good luck with your hosts support team!

  19. ChristiNi
    Member
    Posted 2 years ago #

    Hello again sameermanas,

    So sorry to hear that this is still on going for you. It might be worth picking up the phone to make sure your host has received your request. Errors can happen. Perhaps they either didn't receive your support request or it got lost in the shuffle along the way.

    Hope this is resolved for you soon!

Topic Closed

This topic has been closed to new replies.

About this Topic