WordPress.org

Ready to get started?Download WordPress

Forums

HELP needed. Can't make WP work. (13 posts)

  1. draccan
    Member
    Posted 5 years ago #

    Hi

    I am putting up a WP blog for a friend. I already did one for myself with WP 2.6X working fine. Now I was using 2.7.

    First I did all the regular procedures and struggled with the blog all last night. Finally giving up I did a re-install today. To make sure I didn't do anything wrong.

    The problem I have is mainly with media and uploads.

    I get errors like this not only when uploading but even when trying to display the media section (not every time but like every second time).
    The media seems to be uploaded but the media library admin console has a big list of errors connected with each file.

    I get this error from the admin console:

    Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0
    Fatal error: Unknown: Failed opening required '/home/web/web111385/wp-admin/media-new.php' (include_path='.:/usr/local/share/pear') in Unknown on line 0

    And I get this error for each file:

    Warning: realpath() [function.realpath]: Unable to access /usr/home/web/web111385/wp-admin/wp-content/uploads in /usr/home/web/web111385/wp-includes/functions.php on line 1767

    I have made the folders to 777 (both wp-content, uploads etc).
    Also I have tried several things. I have created a folder called uploads under wp-content and I have made sure the admin console directs downloads there.

    My wordpress address is: http://www.MYDOMAIN.dk
    and I have set my blog address to: http://www.MYDOMAIN.dk/blog.php

    It is weird I have another WP blog working fine on another domain.

    I tried reinstalling everything today and made it in place as I couldnt overwrite the old one.

    As a sidenote I can't find .htaccess neither on my PC nor on my server.
    I have looked everywhere. The same goes for the WORKING WP blog I already have. I use Dreamweaver. I have set both Windows and Dreamweaver up to show hidden files, but I simply can't find .htaccess.

    My webhotel is hosted by Danish company web10.

    I am setting this is up for someone who really needs this. I am in trouble. So help would be appreciated!!

    thanks
    Draccan

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    /usr/home/web/web111385/wp-admin/wp-content/uploads

    That's not right. It's not supposed to be "wp-admin/wp-content/uploads". The "wp-admin" part is not supposed to be there.

    What are the two settings on the Settings->Miscellaneous screen set to?

  3. draccan
    Member
    Posted 5 years ago #

    That's what is so weird, because the settings in Settings->Miscellaneous are:
    Save uploads in this folder: wp-content/uploads
    Full path to files: [blank]

    The three folders are in the root of my domain. Just like one is supposed to do.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    My wordpress address is: http://www.MYDOMAIN.dk
    and I have set my blog address to: http://www.MYDOMAIN.dk/blog.php

    That doesn't sound correct. Why the blog.php? I think this may be what's messing it up.

  5. draccan
    Member
    Posted 5 years ago #

    I can see someone else has had a similar problem:

    http://wordpress.org/support/topic/225717?replies=14

    Maybe there is a bug in WordPress 2.7 hitting some users?

  6. draccan
    Member
    Posted 5 years ago #

    blog.php because I don't want my blog to be index.php

    so I renamed index.php to blog.php
    and then changed the blog address from within the admin console..?

  7. draccan
    Member
    Posted 5 years ago #

    I tried to remove blog.php so both the wordpress and blog address = http//www.mydomain.dk
    And I renamed blog.php to index.php
    but it didn't help me at all..

    I am still getting this when trying to upload:

    Warning: realpath() [function.realpath]: Unable to access /usr/home/web/web111385/wp-admin/wp-content/uploads in /usr/home/web/web111385/wp-includes/functions.php on line 1767

    Warning: realpath() [function.realpath]: Unable to access /usr/home/web/web111385/wp-admin/wp-content/uploads in /usr/home/web/web111385/wp-includes/functions.php on line 1767

    Warning: realpath() [function.realpath]: Unable to access /usr/home/web/web111385/wp-admin/wp-content/uploads in /usr/home/web/web111385/wp-includes/functions.php on line 1767
    17

    And this sometimes when clicking on the media section in admin:

    Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0

    Fatal error: Unknown: Failed opening required '/home/web/web111385/wp-admin/upload.php' (include_path='.:/usr/local/share/pear') in Unknown on line 0

    (getting a blank screen with only this every second time I click something in the media section)..

  8. draccan
    Member
    Posted 5 years ago #

    I really wonder what the problem is.
    I think I have tried everything incl. a total re-install!

    I am blank :'-(

  9. draccan
    Member
    Posted 5 years ago #

    If I put the blog address to the root.
    How do I indicate which is the starting file?
    I don't want to use index.php as the blog is not the index of the site. I would prefer for the blog to start at blog.php.

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I don't want to use index.php as the blog is not the index of the site. I would prefer for the blog to start at blog.php.

    That's not an option. index.php is critical to how WordPress functions. You can't rename it easily.

    If you want it in a subdirectory, like /blog/ then do that instead. But you can't just rename bits and expect it to still work.

    From the other errors you give I expect that you completely hosed the installation by screwing with things too much. My advice is to clear it and start over. And this time, don't change anything. Put it in a subdirectory if you like, but don't mess with any settings or rename any files.

  11. draccan
    Member
    Posted 5 years ago #

    Hi

    I did another re-install. But this time I used WP 2.6.3 instead of 2.7.0

    This time I set everything to http://www.mydomain.com/blog
    So I pretty much did what you said and what the installations said I should do.
    All the files are in the right place.

    I still have a similar error but since the media library works different with less options I don't have the problem there any more.
    I do have the problem when I upload.

    I get this error now:

    Warning: realpath() [function.realpath]: Unable to access /usr/home/web/web111385/blog/wp-admin/wp-content/uploads in /usr/home/web/web111385/blog/wp-includes/functions.php on line 1458
    20

    I believe the problem is still there. Nothing I did so far has changed the problem.

    I wish I could speak to a developer.

    cheers

    Draccan

    Something strange is going on.

  12. jlubeck
    Member
    Posted 5 years ago #

    Were you able to solve this problem? I'm have the same issue. Everything is working, but those warning are very annoying.

    I'm having the same blog installed in two different hostings, one has the warnings and the other hasn't. So I'm guessing it has something to do with the PHP configuration? But I have no clue what to look for...

    Cheers!

  13. m u r
    Member
    Posted 5 years ago #

    same problem.

Topic Closed

This topic has been closed to new replies.

About this Topic