WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Help! Need help changing link in email body! (5 posts)

  1. mynewbff
    Member
    Posted 3 years ago #

    Hi! I'm having an issue with my notification emails. When I tested my site (with a test subscriber), I tested the LOST PASSWORD function, and everything seems to work okay when it sends the link to have you click on it for a request for new password. Then when you get the second email with the new wordpress generated password, it also comes with a wordpress generated link to my site, and when you click on this link, it brings you to a log in page and when you enter the wordpress generated password and log in with it, it redirects you to my dashboard! I do not want subscribers having access to my admin dashboard, and don't know how to fix this! How can I change the link that is in the email body of the "new password" email that is sent out by wordpress? I'm using WP 3.03 with Buddypress, 3 column theme. Any help would be GREATLY appreciated. Thank you!

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    You can try to google for customizing wordpress emails, or something similar

    But, it doesn't redirect to your admin....

    It may do that for you, because you have an admin cookie on your computer, or you're logged in or something...

    But nobody who is not you can gain access to your admin panel. They see their 'admin panel' which is just their profile info. It's the exact same thing they see if they log onto your site normally.

    If I were to register to your site and go to site.com/wp-admin, I would get to that panel. If you allow people to sign up for your site, they automatically get access to that panel. They can't do anything but edit their profile....

    But as long as you allow people to sign up, that is their 'admin panel'. everyone gets directed there whenever they sign in. All your subscribers

  3. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    If people are gaingin access to more than your subscriber level admin panel, then you have a settings issue.

    Make sure in Settings-> general you have 'New User Default Role' set to subscriber.

    And if you are testnig this make sure you have the test account as subscriber. Best thing would be to test from a different computer, or at least using a different browser, one you haven't logged in as an admin from

  4. SoonerJim
    Member
    Posted 2 years ago #

    Hi, I got a long password on my e-mail (for WordPress.org) that I can't find a link to change it. Any ideas? Thanks!

    Jim Whitt
    SoonerJim

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    Please post a new topic.

Topic Closed

This topic has been closed to new replies.

About this Topic