WordPress.org

Ready to get started?Download WordPress

Forums

Help! My WordPress Site Has Some Lag Issues??? (7 posts)

  1. jwack
    Member
    Posted 4 years ago #

    Ive noticed since I have had my wordpress site up that sometimes there is a 6-16 second lag or dead time when loading the site or switching between pages.

    I can not figure out what the heck is going on, sometimes its nice and fast and other times it just hangs. When it hangs it just says "waiting for Mysite.com" in the statis bar. This leads me to believe its the server. Also here is an image that was ran on a testing site, this image shows about a 16 second lag before any data is even sent. Image of server timeline

    This issue has been tested and confirmed on several different connections at different locations. Also, here is my site, sometimes you have to click around for a good few minutes before you see the issue, but trust me its there.

    xbox###video###guides.com

    Im not sure what to do, im about to change hosts (dreamhost) if I can't figure this out.

  2. If you've tested your site via other machines using different ISPs, then it does sound like your web host or the local ISP backbone. But I've tried it and it's fast. Can you use traceroute to find dropped packets and connectivity issue?

  3. jwack
    Member
    Posted 4 years ago #

    traceroute test 1
    1 * * * Request timed out.
    2 * * * Request timed out.
    3 * * * Request timed out.
    4 * * * Request timed out.
    5 * * * Request timed out.
    6 * * * Request timed out.
    7 * * * Request timed out.
    8 * * * Request timed out.
    9 * * * Request timed out.
    10 * * * Request timed out.
    11 * * * Request timed out.
    12 * * * Request timed out.
    13 * * * Request timed out.
    14 97 ms 97 ms 109 ms apache2-dap.falcons.dreamhost.com

  4. I'd tell dreamhost about the connectivity issues and give them the name of that server; if they don't know about it already, they should.

  5. jwack
    Member
    Posted 4 years ago #

    im not sure if im doing something wrong with the tracert, I dont fully understand it but it should connect to something, I mean the site still works.

    I have sent an email to dreamhost already and Im awaiting a response from them. I sent them an the image of the test results but I have a feeling there going to tell me everything looks fine on our end.

  6. jwack
    Member
    Posted 4 years ago #

    My host seems to think its a plugin, I was wondering if anyone knows if any of the following might cause this issue...

    List of plugins...
    smart youtube, tdo mini forms, theme my login, theme my profile, tubepress, wp-flv, xbox 360 gamercard.

    Could it possibly be permalinks?

    Its hard to tell when I disable a plugin if its the cause of the lag because the issue doesn't happen all the time.

  7. Be sure you're runing 2.8.4. Update all plugins.

    Try increasing memory for wordpress by putting this line in your .htaccess file:

    php_value memory_limit 64M

    or this line in your wp-config.php file:

    define('WP_MEMORY_LIMIT', '64M');

    but not both.

Topic Closed

This topic has been closed to new replies.

About this Topic