WordPress.org

Ready to get started?Download WordPress

Forums

help! my posts are not getting displayed (3 posts)

  1. G-Olly
    Member
    Posted 2 years ago #

    Hi, my site was recently hacked. I have gone through it all, changed passwords, secret keys, ftps, etc and got it squeaky clean with some expert help. Using a 503, which allows only me access, I have updated all wordpress plugins and versions so that it will not happen again (I hope). It all works apart from the fact that my posts say "Sorry, but you are looking for something that isn't here.". All my pages are viewable/visible it just seems the posts aren't. It's weird as the wp-e-commerce post types are fine it just seems to be the normal post types that aren't. They are all there when viewed through my admin dashboard. And even when I grab the link from there I still get the can't find page. Can someone maybe tell me where the fault may lie?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

  3. G-Olly
    Member
    Posted 2 years ago #

    Thanks Esmi, I have done all this and my site is clean and so is the database. In fact weirdly enough, the hacker did not insert any trojan, virus or java, just deleted all my files. As I say I have gone through and sorted all this out. I have uploaded from a known safe backup of both files and database, just to make sure. It is just the fact that I cannot now link to my posts, which make up a lot of the site. I wonder whether the upgrade of wordpress or one of the plugins i.e. tgp get posts. Has made this happen. I don't know and wonder if someone has had a same experience? (In essence forget the Hack part.)

Topic Closed

This topic has been closed to new replies.

About this Topic