WordPress.org

Ready to get started?Download WordPress

Forums

Help me. Upgrade failed miserably (5 posts)

  1. erika_conn
    Member
    Posted 7 years ago #

    Trying to upgrade from 2.07. I'm sorry I tried. What a screwup and I did everything by the book.

    First, I got this message when clicking upgrade.php:
    Fatal error: Cannot redeclare timer_stop() (previously declared in /home/cecon46/public_html/canwetalk/wp-settings.php:65) in /home/cecon46/public_html/canwetalk/wp-includes/functions.php on line 840

    Then i went to view the file and got the following:

    <?php
    define('WP_INSTALLING', true);
    if (!file_exists('../wp-config.php'))
    die("There doesn't seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.");

    require('../wp-config.php');
    timer_start();
    require_once(ABSPATH . '/wp-admin/upgrade-functions.php');

    if (isset($_GET['step']))
    $step = $_GET['step'];
    else
    $step = 0;
    @header('Content-type: ' . get_option('html_type') . '; charset=' . get_option('blog_charset'));
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
    <head>
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php echo get_option('blog_charset'); ?>" />
    <title><?php _e('WordPress › Upgrade'); ?></title>
    <link rel="stylesheet" href="<?php echo get_option('siteurl') ?>/wp-admin/install.css?version=<?php bloginfo('version'); ?>" type="text/css" />
    <?php if ( ('rtl' == $wp_locale->text_direction) ) : ?>
    <link rel="stylesheet" href="<?php echo get_option('siteurl') ?>/wp-admin/install-rtl.css?version=<?php bloginfo('version'); ?>" type="text/css" />
    <?php endif; ?>
    </head>
    <body>
    <h1 id="logo"><img alt="WordPress" src="images/wordpress-logo.png" /></h1>
    <?php
    switch($step) {
    case 0:
    $goback = clean_url(stripslashes(wp_get_referer()));
    ?>
    <p><?php _e('This file upgrades you from any previous version of WordPress to the latest. It may take a while though, so be patient.'); ?></p>
    <h2 class="step">"><?php _e('Upgrade WordPress »'); ?></h2>
    <?php
    break;
    case 1:
    wp_upgrade();

    if ( empty( $_GET['backto'] ) )
    $backto = __get_option('home');
    else
    $backto = clean_url(stripslashes($_GET['backto']));
    ?>
    <h2><?php _e('Step 1'); ?></h2>
    <p><?php printf(__("There's actually only one step. So if you see this, you're done. Have fun!"), $backto); ?></p>

    <!--

    <?php printf(__('%s queries'), $wpdb->num_queries); ?>
    
    <?php printf(__('%s seconds'), timer_stop(0)); ?>
    

    -->

    <?php
    break;
    }
    ?>
    </body>
    </html>

    I have a wp-config.php file and it's sitting in the folder. I was told not to overwrite it.

    I can't think of a thing I did wrong. Oh, and BTW, my server has all the latest.

  2. rudolf45
    Member
    Posted 7 years ago #

    When you can see all that code - there is something wrong with the PHP on that server. It looks as if PHP is not running... although that contradicts the fact it worked before.

  3. Samuel B
    moderator
    Posted 7 years ago #

    The very 1st error indicates not all of the wp-includes folder made it or was corrupted in upload. Try re-uploading the contents of that folder.

  4. erika_conn
    Member
    Posted 7 years ago #

    OK, I'll upload wp-includes again and see what happens.

  5. erika_conn
    Member
    Posted 7 years ago #

    Holy moly, it worked!!!!!!!!!!!!!!! Thank you so very much.

Topic Closed

This topic has been closed to new replies.

About this Topic