WordPress.org

Ready to get started?Download WordPress

Forums

Iconic One
[resolved] Help in 404 error on custom.css file (8 posts)

  1. Kreative71
    Member
    Posted 1 year ago #

    Hello,

    I am using your free theme and i will buy the pro version in a few weeks.

    Just testing the free version.

    But i need a little help.

    I don't have any child theme setup, but i make some tweaks in custom.css file in wordpress editor.

    When i run 404 redirect it shows me 714 404 error pages !
    The view log show me this message:

    http://www.aventuradeumblogger.com/wp-content/themes/iconic-one/style.css?ver=3.6

    Can you help me ?

    Thanks

  2. Kreative71
    Member
    Posted 1 year ago #

    I am usin wordpress 3.6 and both files style.css and custom.css are in directory: /public_html/wp-content/themes/iconic-one

    my custom.css:

    /*
    Theme Name: Themonic
    Custom CSS Template for Iconic One.
    */

    a {
    color: #007CC2;
    font-size: 15px;
    text-decoration: none;
    }

    .entry-header .entry-title a {
    color: #007CC2;
    font-size: 28px;
    margin-bottom: 20px;
    text-decoration: none;
    }

    .entry-header .entry-title {
    color: #007CC2;
    font-size: 28px;
    margin-bottom: 20px;
    text-decoration: none;
    }

    hgroup a {
    color: #000000;
    font-size: 34px;
    font-weight: bold;
    padding-left: 10px;
    text-decoration: none;
    }

    .widget-title {
    color: #000000;
    font-size: 16px;
    }

    .widget-area .widget a {
    color: #007CC2;
    font-size: 98%;
    text-decoration: none;
    }

    a.comment-reply-link, a.comment-edit-link {
    color: #007CC2;
    font-size: 13px;
    line-height: 1.84615;
    }

    blockquote {
    margin: 1em 3em;
    color: #999;
    border-left: 2px solid #999;
    padding-left: 1em;
    }

    .avatar {
    -moz-border-radius: 50%;
    -webkit-border-radius: 50%;
    border-radius: 50%;
    height: 40px;
    width: 40px;
    }

    .socialmedia img {
    border: 2px solid #CCCCCC;
    border-radius: 18px;
    }

    Thanks.

  3. Kreative71
    Member
    Posted 1 year ago #

    Hi I think i found it.

    Sometimes to obvious to see at first time.

    I have to put the file in root directory or i have to make a redirect to directory /wp-content/themes/iconic-one/custom.css

    In the file style.css i have : @import url("/custom.css");

    But the custom.css file are in the theme folder /wp-content/themes/iconic-one/custom.css

    Thanks.

    By the way the theme is excelent. Will buy pro version.

  4. Ajay
    Member
    Posted 1 year ago #

    I modified the style.css line to:

    @import url("custom.css");

  5. Kreative71
    Member
    Posted 1 year ago #

    Hi Ajay,

    So simple !

    That's it.

    Is that the best way isn't it ?

    I have to manage the 404 errors !

    Can you give me some advice ?

    I am using 404 Redirect plugin.

    Thanks

  6. Ajay
    Member
    Posted 1 year ago #

    I had SEO Ultimate installed which monitors 404s. The 404 Redirect is good if you're aware of the 404s.

    I think the best way is what I did above. The issue is that they upgraded the theme without fixing this error.

    Another option is to dump a blank custom.css in your root directory.

  7. Themonic
    Member
    Theme Author

    Posted 1 year ago #

    Hello Guys,

    This issue has been noted and it will be fixed in the next version very soon.

    Regards

  8. Ajay
    Member
    Posted 1 year ago #

    Thank you! Glad to hear this :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic