WordPress.org

Ready to get started?Download WordPress

Forums

HELP! Images not showing! (7 posts)

  1. linkdigger
    Member
    Posted 5 years ago #

    I installed the latest WordPress in a subdomain, in a directory called blog (according to the installation instructions). Everything went fine, except when I make a post and click on the image insert button to install an image, it puts the image in the WP-content directory, but the image doesn't display. I've tried using several images but it just won't display them. Then I chmoded the WP-Content directory to 777, but still the images upload but will not display on the blog.

    The url for the site is: http://www.webofevil.com where you can see the only post, but the image just won't display.

    What do I need to do to get this problem fixed, I'd like to start posting to my new website with WordPress.

    Also the mysql apache database set up and user rights are all working fine.

  2. ClaytonJames
    Member
    Posted 5 years ago #

    The url for that image is this:

    //www.webofevil.com/blog/wp-content/uploads/daffy_story_flickr-150x150.jpg

    but the "uploads" folder does not exist. the image actually sits here;

    http://www.webofevil.com/blog/wp-content/daffy_story_flickr-150x150.jpg

    Use your ftp client to create a directory named "uploads" inside your wp-content directory. ...and chmod your wp-content directory back to 755.

    Re-upload the image to your post, this time making sure that it lands in the uploads folder, not in wp-content. I think the cause for this was that wordpress did not have permission to create the uploads folder on your initial attempt at uploading the image, and you may have overlooked the error/warning message... possibly. Could be many reasons I suppose.

    ...and your blog is actually here; http://www.webofevil.com/blog

  3. ClaytonJames
    Member
    Posted 5 years ago #

    ...and your blog is actually here; http://www.webofevil.com/blog

    ...well it was. it's gone now.

    Best of luck to you.

  4. linkdigger
    Member
    Posted 5 years ago #

    Thanks Clayton, still not working. Here's what I did:

    I reinstalled WordPress into the root of http://www.webofevil.com

    Got it all installed fine.

    I then made the uploads directory within the wp-content directory as you instructed, and then chmoded the wp-content directory back to 755.

    Then I went into the post and tried again to upload the image for the post, but got this error:

    The uploaded file could not be moved to /var/www/vhosts/webofevil.com/httpdocs/wp-content.

    Any ideas what to do next? I sure appreciate your help.

  5. linkdigger
    Member
    Posted 5 years ago #

    I FIXED IT, from information found on this page from user Missingrid: http://wordpress.org/support/topic/243343?replies=12

    I was having the same problem w/ 2.7.1. with images not showing when uploading from computer -- made one change and now it works! I went to Settings > Misc > Full URL path to files and deleted the file path here. I left the file path in the field Store uploads > wp-content/uploads. Saved, went back to new post and voila! Image uploaded from computer and fully showing, yay!

    The problem was the url path was not correct. It only showed wp-content and not upload. But in order to get the image to appear I had to make the upload directory chmod 777, which might be a security problem for my site. Chmod 755 did not work.

  6. webo is learning wordpress
    Member
    Posted 4 years ago #

    I followed these instructions

    and it fixed my problem "
    made one change and now it works! I went to Settings > Misc > Full URL path to files and deleted the file path here. I left the file path in the field Store uploads > wp-content/uploads. Saved, went back to new post and voila! Image uploaded from computer and fully showing, yay! my probleme " from http://wordpress.org/support/topic/273510?replies=5

    It does seem a shame that wordpress should have such problems with uploading .

  7. ClaytonJames
    Member
    Posted 4 years ago #

    I left the file path in the field Store uploads > wp-content/uploads.

    Yes. That would be the correct path that WordPress chooses by default at installation. So in essence, it got changed back to what it was supposed to be, in order for it to work properly.

    It does seem a shame that wordpress should have such problems with uploading

    It seems a lot of those problems are also unnecessary and at times, involve "operator error" or misunderstanding. I guess it all depends on your point of view.

Topic Closed

This topic has been closed to new replies.

About this Topic