WordPress.org

Ready to get started?Download WordPress

Forums

Help! I screwed up my site. (5 posts)

  1. jeffcichocki
    Member
    Posted 1 year ago #

    I just installed a new site successfully. I was using a site that I previously had up and running as a model. I accidentally overwrote the wp-config.php file with the one from the original install folder. Now my old site thinks its a new site and wants to run the install again. I'm afraid to do anything with it for fear I'll lose everything and have to start over.

    Can anyone help?

    Jeff

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    http://codex.wordpress.org/Installing_WordPress#Step_3:_Set_up_wp-config.php
    Has instructions for modifying wp-config

    You will need to edit it with all the details of your existing database. You should be able to get all that info from your hosting account.

    Once that is done, make a backup of all your files so you never have to worry again!

  3. jeffcichocki
    Member
    Posted 1 year ago #

    That was the first thing I did. I copied and pasted the settings to make sure I didn't have any typo's. Unfortunately for me, it still doesn't work. I've triple checked the information, and I just can't see what's different.

    Is there anyone that is trustworthy that can look at for me? I wanted to build another site myself to learn, but web stuff is definitely not my expertise.

  4. jeffcichocki
    Member
    Posted 1 year ago #

    What happens if I run the install again? How much of my site do I lose? Plug-ins? Themes? Content? DB?

    Thanks

    Jeff

  5. jeffcichocki
    Member
    Posted 1 year ago #

    OK. I deleted the wp-config file and then let the site rebuild it for me. It's not the DB access that's the problem because after it rebuilds the file and connects, it still wants to install the site again. So, I backed everything up and then let it re-install the site. It does a complete reset to default. That's not a good thing. Where else can I look to figure out why it wants to re-install? It's clearly not the wp-config file.

    I've restored everything back to it's broken state.

    Anyone have any other suggestions?

    Is there a way to let it re-install itself and then bring the old site back in?

    Jeff

Topic Closed

This topic has been closed to new replies.

About this Topic