WordPress.org

Ready to get started?Download WordPress

Forums

Vantage
Help, hover on menu. (13 posts)

  1. HaloBing
    Member
    Posted 7 months ago #

    Hi can anyone help me with this:

    When you enter at site:

    http://www.apartmens-pliva.com

    You will see language chooser, now can i make that

    .main-navigation ul ul li:hover > a {
    
    background: #00bcff;
    
    color: #FFFFFF;
    
    }
    pass by chooser

  2. Andrew
    Forum Moderator
    Posted 7 months ago #

    Are you sure you need to go 2 <ul> levels deep?

  3. HaloBing
    Member
    Posted 7 months ago #

    that is default css on this theme i think because i didnt change anything

  4. Andrew
    Forum Moderator
    Posted 7 months ago #

    Where are you adding your CSS modifications?

  5. HaloBing
    Member
    Posted 7 months ago #

    at bottom of style.css

    but here I think is problem in conflict that qtrans dont have hover and <nav> have it so, css is applying on qtrans

  6. Andrew
    Forum Moderator
    Posted 7 months ago #

    I can't see that CSS modification (the code in your original post) in your Child Theme style.css file http://apartmens-pliva.com/wp-content/themes/vatange-child/style.css?ver=1.1.2

    Are you sure you're working on the right file?

  7. HaloBing
    Member
    Posted 7 months ago #

    under

    /* Dodane stvari */

    translate : (Added stuff)

  8. Andrew
    Forum Moderator
    Posted 7 months ago #

    Put this at the bottom of your Child Theme style.css file:

    .main-navigation #language li:hover,
    .main-navigation #language li a:hover {
     background-color: none;
    }

    It'll be something like that.

    Make sure you do your changes in the Child Theme.

  9. HaloBing
    Member
    Posted 7 months ago #

    it doesn't work...

  10. Andrew
    Forum Moderator
    Posted 7 months ago #

    It wasn't supposed to, but you get the idea right?

  11. Andrew
    Forum Moderator
    Posted 7 months ago #

    Try this:

    .main-navigation #language li:hover {
    	background-color: transparent;
    }
    
    .main-navigation #language li.lang-en a:hover {
    	background: url(/wp-content/plugins/qtranslate/flags/gb.png) no-repeat;
    }
    
    .main-navigation #language li.lang-rs a:hover {
    	background: url(/wp-content/plugins/qtranslate/flags/rs.png) no-repeat;
    }
  12. HaloBing
    Member
    Posted 7 months ago #

    Yes i know..

    But:

    http://prntscr.com/26jxnz

    .main-navigation .qtrans_language_chooser li:hover,
    .main-navigation .qtrans_language_chooser li a:hover {
     background-color: none;
    }

    http://prntscr.com/26jy4h

    .main-navigation .qtrans_language_chooser li:hover,
    .main-navigation .qtrans_language_chooser li a:hover {
     opacity: 0.4;
    }

    well line is ok but how to disable :/

  13. HaloBing
    Member
    Posted 7 months ago #

    I had to change 2 lines

    .main-navigation ul li :hover {
    background: #00bcff;
    color: #FFFFFF;
    }

    to
    .main-navigation ul li :hover {color: #FFFFFF;}

    and add

    #qtranslate-chooser li:hover {
    	background:none;
    }

    thank you on tips :)

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.