WordPress.org

Ready to get started?Download WordPress

Forums

Help! Every page EXCEPT home page became a 404 error (6 posts)

  1. schwinghamer
    Member
    Posted 3 years ago #

    I have a wordpress site dedicated to law at http://www.NfsEsq.com. I host through 1and1.

    Today, I was installing wordpress on a second domain name, also hosted through 1and1. I think I must have accidentally transferred or deleted something to my law blog's site because now the http://www.nfsesq.com loads only the front home page. Every other link leads to a 404 error.

    I can still log into wordpress admin area and see that all my posts and pages are saved there, there's just no way to view them. Even if I click the "view page" feature from within the wordpress admin area, it will load a 404 error page.

    Please someone help!

  2. @mercime
    Volunteer Moderator
    Posted 3 years ago #

    Some thoughts:

    - Did you use the same database used in your first site for your second site? Major overwrite/conflict if you did not change DB prefix for 1st one and didn't change DB prefix for seoond.

    - backup database, export XML just for good measure then run Settings > Permalinks again. clear cache.

  3. schwinghamer
    Member
    Posted 3 years ago #

    I am kind of a novice when it comes to wordpress.

    How do I expert my backup my DB and expert XML? Also, are all my posts saved somewhere in the mySQL database associated with my site?

    If so, can I just re-install a fresh install of the wordpress files to my old website to fix my problem?

    Thanks for the info

  4. mercime - WordPress normally tells you 'Hey! There's a WP install here already!' if you try that :)

    Also, are all my posts saved somewhere in the mySQL database associated with my site?

    Should be, but you really need to go check :)

    http://codex.wordpress.org/WordPress_Backups

    I think you whacked your .htaccess file and broke your permalinks.

  5. schwinghamer
    Member
    Posted 3 years ago #

    Thats it! I am 90% sure I messed up my .httaccess file. Can you tell me how to fix that?

Topic Closed

This topic has been closed to new replies.

About this Topic