WordPress.org

Ready to get started?Download WordPress

Forums

Help editing default theme (8 posts)

  1. badlydrawnboy
    Member
    Posted 8 years ago #

    Hello,

    I'd like to change the size of the text in the header of the default theme. I have a very basic understanding of CSS. I went to the "header template" pane in the Theme Editor section of WP, and saw (I think) that the name of the title class is "header" and the name of the description class is "description". Then I went over to the "stylesheet" pane and changed the text sizes for each of these classes. When I viewed the site, and refreshed, no change at all. What am I doing wrong?

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    That sounds like you are doing it correctly.
    It could be the cache getting in the way.
    Delete everything inside wp-content/cache and see if that helps.

    If it does, you might want to turn the cache off while you do theme changes. Download and open 'wp-config.php' and just above the "Stop editing here" line, paste this:
    define('DISABLE_CACHE', true);
    save, upload.

    Once all is good you might want to remove that line - or leave it. Your choice :)

  3. badlydrawnboy
    Member
    Posted 8 years ago #

    Thanks for your help. I'm a total newbie with this stuff.

    There was no "cache" in my wp-content directory on my web server. Just two folders: plug-ins and themes. Am I looking in the wrong place?

    I did turn off the cache as you instructed. What's the disadvantage of leaving it off, if any?

    Thanks again.

  4. badlydrawnboy
    Member
    Posted 8 years ago #

    Not sure if I made this clear in the last post, but I'm still not able to make the changes I want to make. Any ideas why I'm still having problems?

  5. petit
    Member
    Posted 8 years ago #

    When you select a file, as the style.css the themes editor page, did you check if it is indeed editable.
    If it is not, this comment will show under the editor:

    "If this file were writable you could edit it"

    If it is editable, the above line is not present.
    If on the other hand you do see this statement, it means that you have to change the permissions on the file using your upload client ( FTP, SSH ), and change the permission to 666, giving the web server write access.

  6. badlydrawnboy
    Member
    Posted 8 years ago #

    I don't see the "if this file were writable you could edit it" message anywhere, but perhaps I'm missing it.

    How do I change the permissions of the style.css file? I use Transmit as my FTP client.

  7. badlydrawnboy
    Member
    Posted 8 years ago #

    Okay, I figured out how to change the permissions. Still, nothing is happening.

    When I click "update file" in the editor, I even get a message that the "file is updated successfully".

    Arrgghh! I'm getting really frustrated!

  8. petit
    Member
    Posted 8 years ago #

    My last straw to this will be: There is another cache to consider - the one in your browser. Sometimes, when you work hard on your site, you reload the same page time and again.
    And you see no change because the old version of the page is loaded from the browser cache.

    To see if this is the problem, go to your browser options and empty the cache and maybe you should delete files too.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.