WordPress.org

Ready to get started?Download WordPress

Forums

HELP! Comment box not appearing under posts in Twenty Eleven Theme (8 posts)

  1. ladybajan
    Member
    Posted 2 years ago #

    Yeah, I just noticed that my comment box is not appearing under posts in the Twenty Eleven theme and the "Leave a Reply" button does not work either. The "allow comments" box is checked but it is still not showing up. The comment box would appear in my page section (but I unchecked the allow comments in that section) so I don't understand what is going on. I haven't changed the code from its default unless deleting a plugin can cause this glitch. Is there something that I am not doing?

  2. ladybajan
    Member
    Posted 2 years ago #

    This is the code for the comments.php:

    [please use the http://pastebin.com/ for any code longer than 10 lines - http://codex.wordpress.org/Forum_Welcome#Posting_Code ]

  3. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    The "allow comments" box is checked

    good, however, this will only effect posts made after the change of that setting;

    do you have comments enabled for each individual post?

    either from dashboard -> posts and the quick-edit below each post name;
    or below the post editor - if there is no discussion area, click the 'screen option' tab near the top right, and tick the 'discussion' box, then scroll down to make the settings below the post editer.

  4. ladybajan
    Member
    Posted 2 years ago #

    Yes the comments are enabled for each post. Though thanks for tip on adding the discussion area because it does make it easier to see everything.

  5. ladybajan
    Member
    Posted 2 years ago #

    Okay I updated my theme in order to reset everything and the comment boxes are working now.

  6. lottrr
    Member
    Posted 2 years ago #

    Since the middle of January the "allow comments" checkbox is now missing when making a new blog post. I am using the latest version of WordPress and the Twenty-eleven theme. The discussion and comments boxes are checked in the screen options. I can do a "quick edit" of the post and there is an "allow comments" box, but it does not show up when doing a full edit or new post. The appropriate boxes are checked in the "Discussion Settings" for the site.

    This seems to be a theme issue, but I have not found any discussion that addresses quite this issue.

  7. vahost
    Member
    Posted 2 years ago #

    I'm having the same symptoms as you, lottrr. Did you ever find a solution?

  8. zeus1956
    Member
    Posted 1 year ago #

    I'm having similiar problems.My reply box is white against a black background and you cannot leave a reply. All boxes are checked for commenting. Using 3.4.1 wp

Topic Closed

This topic has been closed to new replies.

About this Topic