WordPress.org

Ready to get started?Download WordPress

Forums

Help Appreciated ! Stylesheets and images urls not loading in iis (2 posts)

  1. Felix2001
    Member
    Posted 3 years ago #

    hi,

    I've got multisite almost running. I want to use sub-directories. I have searched around a lot to find a solution but most people are running Apache, and I am running IIS on windows server 2008. I have complete access to the server.

    when I visit any of my sub-sites (via network admin->sites->visit) I get the html content without the style sheet loading. (or images)
    e.g. it's looking for:

    http://auscms02/wp1/conf01/wp-content/themes/twentyten/style.css
    which does not exist.
    http://auscms02/wp1/wp-content/themes/twentyten/style.css
    whereas that does exist.

    where my main site and wp install is at http://auscms02/wp1/
    my 1st subsite is http://auscms02/wp1/conf01/
    my 2nd subsite is http://auscms02/wp1/conf02/

    http://auscms02/wp1/conf01/wp-admin/ (throws a 404 not found error)

    I am running IIS not Apache, so I have the web.config file located in the wordpress install directory as per the instructions when I created the network. I have url rewrite installed. (http://www.iis.net/download/URLRewrite)

    I'm just wondering what I'm missing? Or if I need an extra step to get this working with url rewrite?

    Many thanks for your help or pointers!

  2. Felix2001
    Member
    Posted 3 years ago #

    I found someone else with the same problem, editing the web.config file as per below seemed to fix it.

    <rule name="WordPress Rule 5" stopProcessing="true">
    <match url="^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*)" ignoreCase="false" />
    <action type="Rewrite" url="{R:1}" />
    </rule>

    Does anyone know if there are any other mods I should be making to the web.config?

    cheers!

Topic Closed

This topic has been closed to new replies.

About this Topic