WordPress.org

Ready to get started?Download WordPress

Forums

Toggle The Title
[resolved] Hello great plugin but i'm getting an error msg below (8 posts)

  1. jcolome
    Member
    Posted 5 months ago #

    Warning: Missing argument 2 for TitleToggler_hide_title() in /home/localmia/public_html/wp-content/plugins/toggle-the-title/main.php on line 103

    see actual site here:

    http://localmiamiguide.com/miami-seaquarium/

    using version 1.3 of your plugin

    please advise and thanks

    https://wordpress.org/plugins/toggle-the-title/

  2. jcolome
    Member
    Posted 5 months ago #

    anyone here ?

  3. avner.komarow
    Member
    Plugin Author

    Posted 5 months ago #

    how did i missed this issue? :-)

    are you working with pages or posts? (this plugin only intended for pages).

    if you are working with pages, lets do 2 simple tests (don't re-enable after each step):
    1) try to disable all other plugins.
    2) try to switch to one of the default themes (twentyXX)

    also please include the following information:
    1) what version of WP
    2) what version of the plugin?
    3) what theme are you using?

    avner.

  4. hpd-fff
    Member
    Posted 5 months ago #

    I am getting this as well.

    I can force it by using the display posts shortcode plugin on http://www.hpd-fff.com/been-there-fished-that/

    I do not get the error unless the shortcode is present.

    Hope this helps, please let me know.

  5. avner.komarow
    Member
    Plugin Author

    Posted 4 months ago #

    hpd-fff :
    i cant seem to recreate the Warning, but i have a good idea way it's happening.
    please try the to relapse in line 103 this line:

    function TitleToggler_hide_title($title, $id) {

    with this line:

    function TitleToggler_hide_title($title, $id = '') {

    and let me know if that resolves the problem. if it dose i will add it to the production version.
    thanks.

  6. HiveError
    Member
    Posted 3 months ago #

    Hi, encountered same warning today using Toggle The Title together with SimplyYearlyArchive and fixed it by setting $id = null as default parameter and doing a null check. Only Afterwards I found the bug report here. Tested your fix above with $id = '' and it works just as well.

    cheers and thanks for the great plugin :)

  7. avner.komarow
    Member
    Plugin Author

    Posted 3 months ago #

    hi HiveError
    thanks for the update! :-) this is a tremendous help because for some reason i can't recreate the big locally on my machine.
    i will upload a new version as soon as i can that will include some other minor updates.

  8. avner.komarow
    Member
    Plugin Author

    Posted 3 months ago #

    added the above fix to 1.4...

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.