WordPress.org

Ready to get started?Download WordPress

Forums

Header wont go "Down" and wont show (14 posts)

  1. chocoloco
    Member
    Posted 8 years ago #

    I have a problem again * sorry, im such a dumbo, i'm a first-time template tweaker *

    http://www.gizmocircle.com

    the header just won't show, and won't "go down" ! :( Any suggestions?

  2. maerk
    Member
    Posted 8 years ago #

    Hey, don't apologise for being a beginner, everyone has to start somewhere!

    What do you mean when you say that the header won't "go down"?

  3. chocoloco
    Member
    Posted 8 years ago #

    please check http://www.chocobay.com

    the header won't show up as a whole ! :( I dont know which aspect to fix on the stylesheet :(

    drat, it's been a month since im fixing these babies.

  4. Doodlebee
    Member
    Posted 8 years ago #

    You have #header set as 100px tall, but your background image is 248px tall. Thta's one big issue right there - your #header div isn't tall enough to show the entire image. You need to either resize your image, or change the height of your #header div.

  5. chocoloco
    Member
    Posted 8 years ago #

    wow you're good mr doodlebee. thank you for figuring that out :) thanks thanks :)

  6. chocoloco
    Member
    Posted 8 years ago #

    another issue, i set the header's height to 300 for some allowance, but it still showed like that :(

    a question though, how can i "place" the header way below the search bar, and move the topbar ( that contains the adsense link units ) down ? :)

  7. Doodlebee
    Member
    Posted 8 years ago #

    First of all, I'm "Miss" Doodlebee ;)

    Secondly, I don't see your header image at all - there' sno call for it. it's not set as the background for your header div, and you aren't calling it in for your image in the HTML - you have this:

    <img src="http://chocobay.com/wp-content/themes/adsmindedwide" alt="" />

    But no image (the final part of that url should end in ".jpg" or ".gif" or something - so no image is being shown)

    Third of all, your #header is *still* set at 100px in height. If you changed it, you didn't save your changes.

    And fourth: If you want your ads to show *above* the header image, then you need to move it's placement. Right now, in your HTML, you have the script source for your ads *within* your header tag *and* below the image call. If you want it above, you need to move those scripts.

  8. chocoloco
    Member
    Posted 8 years ago #

    Hi miss doodlebee! :) Well I got all frustrated last night that I reset everything. I shall look for that
    <img src="http://chocobay.com/wp-content/themes/adsmindedwide" alt="" />

    :) I'll update in a few hours :)

  9. chocoloco
    Member
    Posted 8 years ago #

    Hi Miss Doodlebee ,

    Here's what I have done

    - I have already adjusted the size of my header to 980 px width and 240 px height.

    I have already adjusted the codes too :

    #header {
    left: 0px;
    top: 42px;
    height: 240px;
    width: 980px;
    background: url(http://static.flickr.com/72/172648663_ad169ce826_o.gif) scroll 0% 0%;
    clear: both;
    }

    But upon checking http://www.chocobay.com, it seems that the header still won't fit. It's too "up", and it gets cut off in the middle. What aspect of my stylesheet should I modify to be able to make the header fit? Thank you so much for your help.

  10. yosemite
    Member
    Posted 8 years ago #

    Note: In xhtml, you have to close elements. So, if you are going to use br, close it: br/

    That is a FORWARD slash, btw.

    I played with your css for a bit and it's a mess because of the invalid html. Fix the validation errors, then if you're still having problems, report back ;')

  11. chocoloco
    Member
    Posted 8 years ago #

    Hi Yosemite! :)Thank you for helping me out. So, are you saying that my main error is using <br> instead of <br/> ? :)

    I have fixed all <br \>'s to make it <br> or <br/> already.

    I think those are the only problems since I haven't really changed anything with the template codes.

  12. chocoloco
    Member
    Posted 8 years ago #

    Hi, I have corrected every <br \> or <br> into <br/>'s already.

    I still dont know where i went wrong with the header, why it just won't fit :( wah...

  13. yosemite
    Member
    Posted 8 years ago #

    I think there is a fundamental problem here with communication (understanding what we call validation errors). This link: http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.chocobay.com%2F shows 66 of them.

    It also shows a dozen or more br's that are not closed.

    There are another dozen or so inline element errors that effect displaying your page (ul, li, p not closed, not opened, etc.).

    I have fixed all <br \>'s to make it <br> or <br/> already.

    In reality, this is not the case. When you make a fix or change, run it through the validator again.

  14. chocoloco
    Member
    Posted 8 years ago #

    I really have no idea on how to correct those that you have mentioned :( I'm no CSS expert and this is just my first theme to tweak. Oh well, que sera, sera. Thanks for your advise.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.