WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
[resolved] Header title encoding problem with '&' in Home title setting (4 posts)

  1. nattyait
    Member
    Posted 10 months ago #

    After upgrade All-in-one-SEO to version 2.0.3.1, I've found problem with & character in Home page, here is the reproduce steps:

    Reproduce steps:
    - set Home title in "all in one seo > general settings > Home Title" I've set it to "Computer & IT Support"
    - generate a page and set it as Home ( Settings > Reading > Front page display)

    Observation:
    - On Home page title, it shows "Computer & IT Support" instead of "Computer & IT Support"
    - even I override SEO title on the page and created, it's still using Home Title in plugin global setting.

    Expect:
    - On Home page title, it should show "Computer & IT Support"

    I've done hot-fix to the line 1715 from

    return $this->paged_title( $title );

    to

    return $this->html_entity_decode(paged_title( $title ));

    So, the code after fixed looks like this

    if (empty( $title ) )
    				$title = $this->internationalize( get_option( 'blogname' ) ) . ' | ' . $this->internationalize( get_bloginfo( 'description' ) );
    //				$title = $this->internationalize( get_option( 'blogname' ) );
    			return $this->html_entity_decode(paged_title( $title ));

    I'm not sure what is the root cause for this problem because it doesn't happen with the title setting on other places. If it's really a bug, please kindly fix it in the next version. Or if anything suggestion, please let me know.

    http://wordpress.org/plugins/all-in-one-seo-pack/

  2. ksalks
    Member
    Posted 10 months ago #

    Same thing happens with apostrophes (as well as ampersands) – would also appreciate this being fixed in the next update!

  3. Peter Baylies
    Member
    Plugin Author

    Posted 10 months ago #

    ksalks,

    This was a bug, I've fixed it now; you can update by deleting and reinstalling the plugin.

  4. ksalks
    Member
    Posted 10 months ago #

    Thank you!

Reply

You must log in to post.

About this Plugin

About this Topic