WordPress.org

Ready to get started?Download WordPress

Forums

Header & other images only working on my machine?? (5 posts)

  1. m90010
    Member
    Posted 3 years ago #

    Please Help!

    I'm very new to blogging and have no experience with any code. I am however a designer so I do know my way around most programs.

    I bought a domain using Bluehost to setup my WordPress blog.
    After-which I decided to use the Elegant Grunge theme to skin my blog.

    Problem comes in when I want to include a custom header or custom images for my buttons (like the share button from a plugin)

    The setting require a URL address to locate the images. I loaded them up onto my Bluehost file directory and it all seemed to work fine until I tested it out on another browser or another computer, which display non of the custom header or button images.

    I'm not too sure what I'm doing wrong??

    I would really appreciate it if some super blog genius could hold my hand through this slightly irritating process.

    Thanks
    Matt

  2. bh_WP_fan
    Member
    Posted 3 years ago #

    Site link?

  3. m90010
    Member
    Posted 3 years ago #

  4. Shadowz
    Member
    Posted 3 years ago #

    Are you sure you are using the right url link for the pictures on the host.

    Im not sure but its possible you might be using a address thats related to pictures on your computer. Make sure you have the right url from the pictures on bluehost like "http://www.bluehost.com/dev/pictures/image.jpg"
    The url address should end with the image file name and start with http.

    Just thought i put that out there.

  5. bh_WP_fan
    Member
    Posted 3 years ago #

    The link to your image is looking here: http://www.mattboy.net/images/header.jpg

    However, there is no such image at http://www.mattboy.net/images/header.jpg

    You need to make sure your images are uploaded to the correct spot. I think your link is setup to go to images/ instead of wp-content/uploads/ which is where it normally goes. Or, if it is a theme image, it goes to wp-content/themes/nameofyourtheme/images or something like that.

    You might want to check in your dashboard at Settings > Media and make sure your upload path is set to wp-content/uploads (no slash before wp-content, or after uploads)

    Then re-upload your images and make sure they go to the right spot.

    You may need to manually update any non-working images on your site to find the right path or, if there are a lot of images which need updating, and if you feel comfortable with it, you can use a search and replace plugin to correct them, but make sure to backup your database first just in case.

Topic Closed

This topic has been closed to new replies.

About this Topic