WordPress.org

Ready to get started?Download WordPress

Forums

Header Not Showing Up (5 posts)

  1. rogo2000
    Member
    Posted 7 years ago #

    Hey everyone:

    I've had a pretty serious problem with my blog since I tried to upgrade to 2.2 the other day. For some reason, my header is no longer showing up no matter what I do. Even stranger, when I go to pick my theme, NONE of the themes (either the pre-installed default/classic themes or the ones I have downloaded) show up -- I can choose them, but I can't see them.

    To see what I mean, you can check out my blog to see the missing header, and you can check out this screenshot to see what I mean about the themes.

    Anyone seen this before? Any thoughts?

    Thanks!

    Steve

  2. sarasaratricecom
    Member
    Posted 7 years ago #

    It looks like there is something pretty seriously wrong with your images on your server, which doesn't seem like a wordpress problem. For example, if I go here, where your header image should appear:

    http://blog.rogomo.com/wp-content/themes/Mandingo/images/header.png

    I get:
    "The image “http://blog.rogomo.com/wp-content/themes/Mandingo/images/header.png” cannot be displayed, because it contains errors."

    Has anything else with your server changed, or maybe some problem with your .htaccess?

  3. rogo2000
    Member
    Posted 7 years ago #

    Actually, all of the files are in /blog/, so the file you're looking for is here:

    http://www.rogomo.com/blog/wp-content/themes/Mandingo/images/header.png

    That said, nothing shows up, so I don't know wha that means.

    Nothing should have changed with the server as far as I am aware... thanks for your time and thoughts!

    Steve

    Edited to add: I think I may have just figured out the problem. Will test my theory and re-post if it works.

  4. rogo2000
    Member
    Posted 7 years ago #

    PROBLEM RESOLVED.

    Some idiot (i.e., me) had changed my FTP upload settings to ASCII for something I had done the other day, and forgotten to change it back to Auto. When you mentioned that my images were screwed up, it suddenly dawned on me, so thanks!

    Steve

  5. Hanenwurger
    Member
    Posted 7 years ago #

    If you already deleted (or renamed) the file 'header-img.php' in the images-folder (because it removes the kubrick-gradient), this will also result in an absent header.

    In WordPress 2.2 you can fix this by removing the following code in the page 'header.php':

    <?php wp_head(); ?>

    This line calls the gradient function in the kubrick-header. Once you have removed it, the gradient will disappear as well.

    Make sure your CSS catches up all the necessary graphic information to replace it with your personal header.

Topic Closed

This topic has been closed to new replies.

About this Topic