WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Header images not showing on pages (4 posts)

  1. AGriffin89
    Member
    Posted 4 years ago #

    I'm pretty new to WordPress so I may be missing something really obvious.

    The header is displaying fine on the main posts page however, whenever I add new pages the headers images won't displayed, see: http://everythingaustin.com/austin/

    Any help would be much appreciated.

    Thanks,

    Aimee

  2. conorp
    Member
    Posted 4 years ago #

    The actual image is at: http://everythingaustin.com/wp-content/themes/vampish-austin/images/slice_003.png

    And the Austin page links to: http://everythingaustin.com/austin/wp-content/themes/vampish-austin/images/slice_003.png

    Not really sure how your coding the theme so its hard to tell you exactly what to fix. Its not ideal but you could hardcode the image. Ie: put the src directly as the image rather than /....

  3. AGriffin89
    Member
    Posted 4 years ago #

    Thanks for replying. That's all jargon to me, someone else made the layout for me :)

    The code for the theme is:

    <?php get_header(); ?>

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>

    <div class="main">
    <div class="posttitle"><?php the_title(); ?></div>
    <div class="postmain"><?php the_content('Read More of this Page'); ?>
    <?php wp_link_pages(array('before' => '<p>Pages: ', 'after' => '</p>', 'next_or_number' => 'number')); ?></div>
    </div>

    <?php endwhile; endif; ?>

    <?php get_footer(); ?>

    Do I want to be changing that?

  4. AGriffin89
    Member
    Posted 4 years ago #

    I've managed to sort it out. Many thanks for your help :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags