WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Header image won't upload. (13 posts)

  1. Mascole07
    Member
    Posted 10 months ago #

    I try to change the header via the custom header link in appearance, i'm able to get as far as the crop and publish page but when I click ok (i've tried both options 'use image as is and publish' and 'crop and publish') it doesn't load, all I get is a white page. Also on occasion I get a html error when I try to upload an image via the media uploader.

    everything was working fine until I updated to the latest wordpress a couple of days ago.

    I have checked my media settings, changed the permissions, reinstalled and rolled back wordpress, deactivating and uninstalling all plugins, I've tried uploading the image directly to cpanel but no luck.

    Here is a link to what I am getting--> imgur.com/lSJlUO0

  2. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    Have you tried deactivating all plugins and switching to the default theme to see if any are causing that to occur?

  3. jeb.baxley
    Member
    Posted 10 months ago #

    stupid question, but have you tried clearing out your cache on your browser?

    also, are your plugins still disabled, or did you turn them back on?

  4. Mascole07
    Member
    Posted 10 months ago #

    Thanks for replying,

    I have tried disabling and deactivating all plugins as well as switching themes, I've tried twenty eleven, twenty twelve and twenty thirteen. this is a clean install of wordpress.

  5. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    Link to your site?

  6. Mascole07
    Member
    Posted 10 months ago #

    link

    There are no plugins installed at this time bar askimet and it is deactivated.

  7. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    You've checked the file permissions? Have you asked your hosting company?

  8. Mascole07
    Member
    Posted 10 months ago #

    Yep checked permissions and tried different combos but no luck. I have emailed my host but they have yet to get back to me.

    Couldn't have anything to do with the new update could it? Everything was working ok until I installed it.

  9. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    You've gone through this on the permissions?

    http://codex.wordpress.org/Changing_File_Permissions

    Updates do sometimes cause problems but if it was an actual WP bug, there'd be tons of people on these forums screaming! Where is your site hosted?

    Do you get any error messages? You should also ask your hosts how to look at the error logs for your site - to see what may be going on when that upload fails.

    BTW, can you upload other images?

    Have you tried a really small image?

  10. Mascole07
    Member
    Posted 10 months ago #

    I'm also getting a html error when I try and drag and drop images through the media tab. Though when I go back in the images are there and I can use them in posts and pages just can't get the header to work....

  11. Mascole07
    Member
    Posted 10 months ago #

    Could this have something to do with my PHP memory?

  12. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    That usually shows up as a fatal error - something like "Allowed memory size of xxxxxx bytes exhausted".

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    You've said "html" error - is that actually "http"?

  13. Mascole07
    Member
    Posted 10 months ago #

    Just an update for this problem.

    It was php memory limit and upload maximum file size limit that was causing the problem. I contacted my host and they were able to increase the limit. So if anyone is experiencing the same issue this is definitely worth trying.

Reply

You must log in to post.

About this Topic