WordPress.org

Ready to get started?Download WordPress

Forums

header image - where (12 posts)

  1. marley1
    Member
    Posted 6 years ago #


  2. Marianne
    Member
    Posted 6 years ago #

    go to your 'header.php' file and look for this line

    /* BEGIN IMAGE CSS */

    everything after that will give the information & instructions for header images in that particular theme.

  3. marley1
    Member
    Posted 6 years ago #

    sorry - but i don't know WHICH file needs the modification. I have gone to:
    Editing header.php under PRESENTATION
    and
    Editing wp-content/themes/default/header.php under MANAGE/FILES

    neither of these files have /* BEGIN IMAGE CSS */

    is there another file I should try. please and thanks. sorry for the double post, but i realized i posted under the incorrect header. i'm so confused, my heads spinning. i have been trying for almost 3 hours to resolve this stupid header image issue!!

    thanks for your help.

  4. moshu
    Member
    Posted 6 years ago #

    1. Modifying the default... is a challenge even for experienced users.
    2. The code quoted by marianne was in earlier versions of the theme.
    3. What happens if you make your image exactly the same size as the original header and you upload it by ftp to the proper location with the same name - overwriting or previously renaming the original kubrick header?
    4. DON'T edit themes online - there is undo button!

  5. marley1
    Member
    Posted 6 years ago #

    the thing is that i can't find the kubrickheader.jpg file anywhere. i have take just about every page of code, cut and paste it into a text editor, searching through for this file.

    if i just knew the path or the acutal file name in a specific folder, it might get me down the road.

    i understand the undo, found that out the hard way, but had access to a virgin wordpress php file so was able to paste it in over my trials.

    thanks for trying to help me... i can't believe it would be this hard!

  6. moshu
    Member
    Posted 6 years ago #

    if i just knew the path or the acutal file name
    THAT's the actual file name: kubrickheader.jpg - you are talking about all the time.

    I am afraid you don't read the replies, do you?
    What I suggested above does NOT require any editing of any file.
    Just plain normal usage of a FTP client which is MUST if you have and want to have a website.

  7. marley1
    Member
    Posted 6 years ago #

    i'm so sorry i'm not making myself clear. it's my fault.

    i understand WHAT the file name is. however, i'm not finding this file name in any of the php files. i don't know what file this kubrickheader.jpg is in.

    i can't replace something that doesn't appear to be existing.

    thanks so much for giving me your time to help me, i appreciate it.

  8. moshu
    Member
    Posted 6 years ago #

    Then lets' get back to the basics.
    The image file is NOT in any .php files. It is just sitting there in the wp-content/themes/default/images folder.

    As EVERYTHING related to style - it is called from the style.css, as a background image.
    (I told you not to mess with the default...)

    Usually, the images for a theme are located in
    wp-content/themes/theme-name/images/ directory

    Did you try to look around on your server with any of the FTP_Clients as it was suggested? If no FTP - no changes to your theme's images. Period.

  9. obnoxshuz
    Member
    Posted 5 years ago #

    Don't know if this'll help but I had a similar problem.

    What fixed it for me was the REVERT under DESIGN / HEADER IMAGE AND COLOR then UPDATE.

    After that my new header art showed.

    Hope this helps.

  10. kelwool
    Member
    Posted 5 years ago #

    I was (am) having the same problem as marley1. When following the tutorial as written here, it says "To change the image file, replace the "kubrickheader.jpg" with the name of the new graphic image you have uploaded to your site to replace it."

    This is incredibly confusing, as not only does the code it is referencing (directly above this quote) not appear in the header.php template, nor does the "kubrickheader.jpg".

  11. MichaelH
    Member
    Posted 5 years ago #

    In my 2.6.3 copy of WordPress, there is a file called kubrickheader.jpg. That file is in the wp-content/themes/default/images folder.

  12. abirdman
    Member
    Posted 5 years ago #

    I had the same problem, trying to change the colors in the gradient page header in the default theme, and here's how I solved it:
    (first my setup:
    OS: Ubuntu jeOS 8.04.1 (virtual machine minimal install), Webserver: Apache 2.2.8, PHP: 5.2.4)

    1. PHP5 must include the GD library. I downloaded and installed into Ubuntu with sudo apt-get install php5-gd It was not available by default.
    2. The jpg file (MichaelH is correct about the location of the file in his post above this one) has to be world writable, or at least writable by the Apache user (on my machine that's www-user). The easiest way to do that is follow the official directions in the detailed instructions on permissions here. What I did was, from the console change to the blog root directory and type chmod -Rv 0777 ./wp-content I do not believe this constitutes a security risk, but if you're worried, change the permissions back to 0755 after you've changed the jpg.
    3. The standard install of PHP5 defaults to 16M of memory for scripts. To change the header jpg, I set the memory to 256M in php.ini.memory_limit = 256M Note that I didn't test too finely, but 128MB did not seem to work. I am going to change the memory back to a more sane amount now that the jpg has been modified.
    4. Restart Apache and you're good to go.

    I have no idea how those steps would be accomplished with a hosting provider, but that's what I had to do with a default installation of Ubuntu 8.04 JeOS (that's the virtual server minimal installation). I hope this helps someone. I see by searching the forums here this is not an isolated problem. It would be good if somewhere WP indicated that the GD libraries are required and that the standard script memory setting is too low.

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.