WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Header image is not adjusting properly (12 posts)

  1. jeffwenberg
    Member
    Posted 3 years ago #

    I am customizing my theme, by adding a header image. The site is here There is something messed up with how the main image is displaying. I can't find that particular setting. According to my css sheet it's already set to a height 370 px , but when you view the page source code in the internet browser there is something set to 179 px on line 41. That's the culprit but I don't know where to find it to change it to the proper 370px. I don't really know how to read the page code. Any help is appreciated.

  2. Michael
    Member
    Posted 3 years ago #

    There is an in-line style that is being used to set the 179px. It is overriding the 370px since it is in-line.

    <style type="text/css">#header .inner{height: 179px}</style> line 41 of HTML.

    Michael

  3. jeffwenberg
    Member
    Posted 3 years ago #

    yes that's what I've discovered as well. My question would be how do I get rid of that in line style?

  4. Michael
    Member
    Posted 3 years ago #

    Try this at line 38 in the style.css.

    #header .inner {
    background:url("images/header_bg.png") no-repeat scroll center center transparent;
    height:370px !important;

    Michael

  5. jeffwenberg
    Member
    Posted 3 years ago #

    Nice! That fixed it Michael, thank you so much! What exactly did we do?

    Would you be able to tell how to disable the @ and the key at the bottom of the grey content box? When I just remove the picture the links are still there, but I just want to disable them.

  6. Michael
    Member
    Posted 3 years ago #

    One solution would be to place then off the page.

    Try this at line 1003 in the style.css

    #page .miniLinks {
    background:none repeat scroll 0 0 red;
    bottom:0;
    height:30px;
    position:absolute;
    right:-220px;
    width:80px;

    Michael

  7. Michael
    Member
    Posted 3 years ago #

    You may want to do that at -330 to get them all the way.

    Michael

  8. jeffwenberg
    Member
    Posted 3 years ago #

    If I did that, would they still potentially show up if someone had a big monitor?

  9. Michael
    Member
    Posted 3 years ago #

    Yes it would.

    This is controlled by these lines at about 1030 in the style.css.

    If you disable the URL in the "#page .miniLinks a" line and delete the color of the "#page .miniLinks" it will disappear.

    #page .miniLinks {
    background:none repeat scroll 0 0 red;
    bottom:0;
    height:30px;
    position:absolute;
    right:60px;
    width:80px;
    }
    #page .miniLinks a {
    background:url("images/icons-links.png") no-repeat scroll 0 0 transparent;
    display:block;
    float:left;
    height:30px;
    position:relative;
    text-indent:-9999px;
    width:40px;

    Michael

  10. Michael
    Member
    Posted 3 years ago #

    You will need to disable the URL on this line so it will not show when you hover over.

    #page .miniLinks span {
    background:url("images/icons-links.png") no-repeat scroll 0 0 transparent;
    display:block;
    height:30px;
    left:0;
    position:absolute;
    top:0;
    width:40px;

  11. jeffwenberg
    Member
    Posted 3 years ago #

    Thank you very much for the help!!!

  12. jeffwenberg
    Member
    Posted 3 years ago #

    Hey Michael, would you be able to figure this out?

Topic Closed

This topic has been closed to new replies.

About this Topic