WordPress.org

Ready to get started?Download WordPress

Forums

Expound
[resolved] Header image disappear on sub page (3 posts)

  1. racemouse
    Member
    Posted 8 months ago #

    Dear Forum,

    I am not very good at web so i hope that someone can help.

    I have a image in the header (the logo) and it will only show one the front page and not when you click on some of the sub pages.

    My site is: http://www.jutlandstation.dk

    Thank you very much in advance

  2. alrmoras
    Member
    Posted 8 months ago #

    Hi, looking at your sites code, to load up the header image on the main page you are going to yoursite.com/wp-content/fakepath/logo.png however, the way that you've set it up is when you go to a new page, it then tries to load yoursite.com/mypage/wp-content/fakepath/logo.png and ofcourse, the logo isn't there.

    <img src="wp-content/themes/expound/images/header/logo.jpg">

    To fix it you will need to go to your directory where your theme is installed goto the 'inc' folder then edit custom-header.php

    Goto around line 64 and make sure that the bit that says <a class="expound-custom-header" href="<?php echo esc_url(
    says
    <a class="expound-custom-header" href="<?php echo esc_url( home_url( '/' ) ); ?>"

    If it still doesn't work, make sure that your home URL is set correctly at the Settings page.

    PS: I wouldnt add your logo in the header image, rather I would add

    .site-title a {
      background: url('http://YourSite.com/Path-To-Image.png') 0 0 no-repeat;
      width: WidthOfImagepx;
      height: HeightOfImagepx;
      text-indent: -9999px;
    }

    Replace YourSite.com/ect... with your logo
    Replace WidthOfImage and HeightOfImage with the correct numbers

    This should be added to your expound.css file located in Theme Directory -> CSS

    Hope I helped :)

    Alex

  3. Konstantin Kovshenin
    Member
    Theme Author

    Posted 7 months ago #

    You should not edit any of the theme's files directly. For any customization, please use a child theme.

Reply

You must log in to post.

About this Theme

About this Topic

Tags