WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Header disappears when using "pretty" permalinks (5 posts)

  1. Melanie Richards
    Member
    Posted 4 years ago #

    The site I'm working on is: http://averyed.com

    All the sections of the site ("pages" in WP language) work when I use the default URL structure, but of course that will frustrate the average user.

    When I use /%postname%/ as the custom, I get a 404 error.
    When I use /%year%/%postname%/ as the custom, it yields the same URLs (since I am using pages) as /%postname%/, but this time the header.php completely disappears when I call it into a page (it still shows up when called into index.php).

    I have moved the codex from a subdirectory to the main directory, but followed directions and didn't change the mySQL database at all. Could moving the codex have affected this?

    Please let me know how to fix this, because I would love to have "pretty" permalinks.

  2. It looks like you did some customization on the theme. It's hard to tell where without seeing your files, but I'll try my best to explain.

    I'm seeing this in your source code where the header is:

    <img src="header.jpg">

    Basically, that's telling the browser to get the image from the-URL-that-I-am-at/header.jpg .

    So, if you're on http://averyed.com/ , the browser is pulling the image from http://averyed.com/header.jpg which works perfectly. But, if you go to http://averyed.com/archives/date/2010/05 , it's pulling the image from http://averyed.com/archives/date/2010/header.jpg which doesn't exist.

    To fix this, find where you made the above addition (probably in your theme's header.php file) and change it to:

    <img src="http://averyed.com/header.jpg" />

  3. f00bar
    Member
    Posted 4 years ago #

    First of all, nice site!

    Changing the default structure would affect the way it works. Unless you specify the directory in the General settings under "WordPress address (URL)" it won't know where to find the header.

    I assume this is what you mean?

  4. Melanie Richards
    Member
    Posted 4 years ago #

    Wow. Thank you macmanx, that's one of the most basic fixes ever. I can't believe I overlooked the direct vs. relative img linking..thanks for solving such a dumb error.

    Thanks for your responses, both of you. It was the URL of the img that was incorrect.

  5. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags