WordPress.org

Ready to get started?Download WordPress

Forums

Openstrap
Header disappears when I select not to show header text with image (4 posts)

  1. kramr10
    Member
    Posted 5 months ago #

    I have been trying to upload a custom header to my site. I've been trying several different images trying to find one that fits best. Now when I select not to show header text in image, the entire header disappears, including header widgets.

  2. Pavan Solapure
    Member
    Theme Author

    Posted 4 months ago #

    If you select not to show header from WP settings then it obvious behaving correctly.

    Try setting the header image using theme options -> basic settings

  3. PaulDoesWP
    Member
    Posted 3 months ago #

    I'm having exactly the same issue - I'd like an image (logo) instead of the text, but I need something to go in the <title> attribute. I don't want the text to appear. But if I turn off 'Display Header Text' under Appearance > Customize, the 'Header Background' image disappears too. If I add an image to 'Site Logo', nothing happens. Where should this appear? I have extensively modified a child of the theme, and also changed some stuff in the main bootstrap.css file when I couldn't get the child theme's style.css to override the bootstrap.css settings, so this might be affecting the non-existence of the Site Logo image. I'd also like the image to be clickable to take the user back to the home page.

    I could theoretically change the h1 tag to have color: transparent, but h1 is used extensively throughout my site.

    Any suggestions would be greatly appreciated.

    - Paul

    UPDATE: I got around this by leaving the Site Title (in Appearance > Customize) blank, but keeping Display Header Text ON. I then edited header.php - I removed the php code from the <title> attribute and replaced it with my site's title. Not an ideal workaround, but it did the job. It'll be a real headache if I ever download an updated Openstrap theme....!

  4. Pavan Solapure
    Member
    Theme Author

    Posted 3 months ago #

    you need to keep the show header text check box on.
    Did you guys try to set background image for header and logo from theme options? Theme Options -> Basic Settings has way to set this.

    Please try and let me know.

Reply

You must log in to post.

About this Theme

About this Topic