WordPress.org

Ready to get started?Download WordPress

Forums

Socialauth-WordPress
hd => domain.com is not working... (3 posts)

  1. Mortrall
    Member
    Posted 1 year ago #

    On this page
    http://hybridauth.sourceforge.net/userguide/IDProvider_info_Google.html
    developers wrote, that "hd" => "domain.com" would prevent registration from the other than this domains. I've added this parameter to /wp-content/plugins/socialauth-wp/hybridauth/config.php

    No luck... All are able to register. From gmail.com, etc. Why is not working?
    It looks like this by the moment:

    "Google" => array (
    "enabled" => true,
    "keys" => array ( "id" => "", "secret" => "" ),
    "scope" => "",
    "hd" => "neededdomain.com"
    ),

    Sincerely,
    Pavel.

    http://wordpress.org/extend/plugins/socialauth-wp/

  2. Mortrall
    Member
    Posted 1 year ago #

    Solved.
    I've added "hd" => "neededdomain.com" at OAuth2Client.php in $params

  3. 3pillarlabs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Mortrall,

    The documentation you have read is correct but we have not yet implemented domain level restrictions which we should.

    This is on our task list for upcoming release. Adding "hd" => "neededdomain.com" at OAuth2Client.php is a shortcut to which we shall put somewhere in admin->settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.