WordPress.org

Ready to get started?Download WordPress

Forums

Having troubles with wp_postmeta query (1 post)

  1. lelandmcfarland
    Member
    Posted 2 years ago #

    I have an old, high traffic site that I am taking care of now. It now has over 6,000 posts. I am now going through the process of optimizing the site. In my slow query log I am coming across this type of query very often.

    SELECT post_id, meta_key, meta_value FROM wp_postmeta WHERE post_id IN (111891,111557,111333,111141,110903,110623,110109,109870,109545,109256,108984,108777,108549,107989,107781,107611,107190,106915,106680,106438,106240,105995,105813,105285,105043,105029,104846,104629,103997,103786,103615,103375,103095,102905,102716,102553,102376,102077,101914,101705,101470,101215,100991,100856,100679,100498,100148,99930,99726,99557,99351,98911,98649,98501,98341,98049,97769,97597,97408,97215,97028,96754,96524,96326,96112,95878,95645,95484,95255,95076,94843,94618,94411,94221,94045,93823,93609,93445,93249,93033,92822,92478,92274,92114,91939,91761,91451,91258,91076,90851,90624,90330,90152,90024,89839,89581,89257,89130,88920,88715,88525,88315,88143,88006,87830,87671,87393,87226,87030,86825,86622,86298,86061,85887,85706,85549,85246,85028,84910,84751,84507,84181,83937,83708,83406,83182,82894,82738,82565,82394,82265,82038,81903,81770,81595,81409,81287,81143,80957,80829,80628,80394,80246,80083,79928,79722,79277,79048,78853,78706,78357,78145,77902,77743,77530,77234,77070,76908,76767,76668,76356,76081,75964,75818,75602,75285,75099,74922,74763,74555,74222,73992,73850,73726,73489,73232,73047,72963,72893,72729,72460,72338,72167,72042,71887,71538,71404,71198,71067,70829,70501,70330,70238,70073,69919,69569,69511,69322,69206,69022,68594,68524,68429,68296,67967,67657,67456,67295,67113,66889,66644,66474,66330,66122,65916,65513,65389,65204,65096,64944,64725,64502,64394,64266,63790,63656,63562,63386,63181,63059,62917,62790,62631,62413,62325,62232,62036,61883,61615,61501,61381,61225,61125,60975,60703,60547,60442,60339,60155,59926,59848,59613,59448,59303,58931,58790,58451,58199,58085,57913,57765,57389,57037,56921,56684,56579,56490,56395,56269,56044,55912,55829,55734,55597,55288,55203,55126,55016,54853,54636,54460,54389,54076,53998,53483,53341,53198,53081,52960,52407,52277,52187,52057,51882,51766,51527,51432,51150,51020,50895,50766,50601,50339,50191,49948,49783,49680,49293,49192,48969,48844,48721,48465,48226,48090,47958,47879,47633,47446,47308,47117,46995,46788,46623,46449,46296,46122,45845,45692,45536,45424,45321,45043,44884,44784,44667,44539,44393,44269,44149,43997,43820,43470,43351,42812,42648,42265,42117,41977,41852,41794,41680,41417,41217,41085,41006,40872,40462,40412,40180,40009,39844,39655,39528,39342,39171,39044,38817,38667,38482,38183,37911,37744,37568,37412,37260,36993,36832,36646,36399,36230,35928,35824,35638,35544,35312,35113,34947,34833,34720,34527,34289,34067,33954,33782,33584,33331,33220,33021,32819,32633,32375,32261,32065,31942,31741,31450,31264,31110,30924,30798);

    I was wondering if anyone else has ran into this type of problem before and found a way to lessen the blow? I currently use WP Super Cache to help speed up the site but queries likes this still slip through. Any help would be appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 2 years ago by lelandmcfarland
  • This topic is not resolved
  • WordPress version: 3.1.4