WordPress.org

Ready to get started?Download WordPress

Forums

Having trouble getting a blog page working (8 posts)

  1. fliski
    Member
    Posted 3 years ago #

    Hey guys,

    Firstly, I have checked a bunch of old threads on this and Im pretty sure Im doing everything right, it's just not working for some reason.

    What I want to do is have a certain page for my blog (the rest static). So what I did was go onto settings/reading and changed the front page to home and the posts page to blog. But what I get when I go on the blog page is

    ''Not found''
    Sorry but you are looking for something that isnt here
    Search for: ______________________search

    If anyone has any suggestions then Im all ears!

    Thanks,

    Dave
    http://www.heavyair.co.uk (the blog page is draft atm)

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    You need to have created and published these Pages before selecting them in Settings -> Reading.

  3. fliski
    Member
    Posted 3 years ago #

    Yes, I have created and published both pages, I just took the blog one down so customers dont see something weird

  4. fliski
    Member
    Posted 3 years ago #

    Ok, so I still have issues here. I have a publised page called blog which I have set to be the blog in settings/reading. I have also published a post.

    The post is giving me a 404- here is the permalink (which looks very strange); http://heavyair.co.uk/http:/www.heavyair.co.uk/page

    And the blog page is here; http://heavyair.co.uk/blog-3 Gives me a 'search for box'

    Is this a problem with the permalink? It won't let me edit the link on the edit part of the page so I have no idea how to change it (if that even is the problem)...

    Anyone got any ideas?

  5. wonderwoman2
    Member
    Posted 3 years ago #

    Can you give the link to the post with the duplicated link?

    I've seen that once before and it turned out to be how I was entering the link information...

  6. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Try resetting your permalinks to default (i.e. "ugly"), and see if the problem persists.

  7. fliski
    Member
    Posted 3 years ago #

    Thats the only link I have..Its what comes up on the 'edit post screen' just above the text box

  8. fliski
    Member
    Posted 3 years ago #

    Ok, I changed the permalinks to default and the search box is still there on the blog page, but it did give me a link to a post; http://heavyair.co.uk/?p=363

    Which works...but doesnt come up on the blog page; http://heavyair.co.uk/?page_id=356

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.