WordPress.org

Ready to get started?Download WordPress

Forums

Having to Log Out To Add Comment in the MX4 Theme (5 posts)

  1. bethchelle
    Member
    Posted 8 years ago #

    If I respond to a comment made to a post-I am using the MX4 Theme-I have to log out completely, fill in my information then submit the comment. If I don't, I get this error message: Please fill in the name, email and comment fields. I am the admin of this WP install yet I have to completely log out? Any help would be appreciated.

  2. Ennis
    Member
    Posted 8 years ago #

    did you mess around with the code any since you installed it? I installed it for my site and i had no problems with it.

  3. bethchelle
    Member
    Posted 8 years ago #

    Not at all. The only changes I made were to the sidebar to add my links and to the header file to replace my file names for the graphics. Other than this, I've not touched any other files.

  4. Ennis
    Member
    Posted 8 years ago #

    under site admin > users > your profile, did you fill out the e-mail address and the rest of the fields....

    to be honest i am not sure what your problem could be. Im just tryin to come up with ideas, someone else may know whats wrong with it.

    do you have this problem with any other themes?

  5. bethchelle
    Member
    Posted 8 years ago #

    I had to remove these lines in order for this to work without the admin of the site having to log out before commenting:

    <?php if ( $user_ID ) : ?>

    Logged in as /wp-admin/profile.php"><?php echo $user_identity; ?>. /wp-login.php?action=logout" title="<?php _e('Log out of this account') ?>">Logout »

    <?php else : ?>

    And at the bottom of the template:

    <?php endif; // If registration required and not logged in ?>

    Since this theme is based on the Kubric theme I don't understand since I briefly used Kubric and never had any trouble. For some reason if the admin was logged in it would not show the name/email fields-it just showed you were logged in and could log out. Strangely enough I'm not that great with php but I managed to figure this out! So if anyone else has this issue-removing these lines worked for me. And thanks for your help!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.