WordPress.org

Ready to get started?Download WordPress

Forums

Having problems with Qtranslate (8 posts)

  1. katiebegood
    Member
    Posted 2 years ago #

    Up until today I have had no problems with using qTranslate other than having to remove a double %% to get the date to work properly. But, starting today, I can't seem to get formatting to stick. I'll format the English version (paragraphs, etc) and then the Spanish version loses all it's formatting. I'll format the Spanish version and the English version loses it's formatting. I've tried doing the formatting directly in html mode (hand coding), but the coding then just disappears. I'm so frustrated I'm about ready to throw my computer out the window. The only thing I've changed is removing that extra "%" in the qtranslate file that controls the formatting of the date. I can't image that would have anything to do with messing up the formatting on the site. Has anyone had a similar problem?

  2. fyllhund
    Member
    Posted 2 years ago #

    http://www.qianqin.de/qtranslate/forum/viewtopic.php?f=3&t=2841&start=140

    fix is my temporary fix is to add this to qtranslate_javascript
    before the ending } tag.

    function cbnet_tinymce_config( $init ) {
    
          // Don't remove line breaks
          $init['remove_linebreaks'] = false;
          // Convert newline characters to BR tags
          $init['convert_newlines_to_brs'] = true;
          // Do not remove redundant BR tags
          $init['remove_redundant_brs'] = false;
    
          // Pass $init back to WordPress
          return $init;

    solves the <p> and
    BREAKS

  3. swearingdad
    Member
    Posted 2 years ago #

    Thanks for the fix - can you tell me exactly where I should paste the code?

  4. katiebegood
    Member
    Posted 2 years ago #

    Actually, I found that if I was in HTML mode when I saved any changes, they took and didn't revert back or switch with the other language. It's a bit of a pain, but it works. As long as I NEVER save while in Visual mode, all changes stick.

  5. swearingdad
    Member
    Posted 2 years ago #

    Appreciate the tip. That's worth knowing but I have at least 30 pages on my site in three languages so I cannot really be editing everything in HTML (otherwise I would have stuck to creating websites the old fashioned way)!

    I have paid for the plugin so hopefully the issue will be addressed. I will just leave the site not updated for a few days and hope for a fix!

  6. brisch
    Member
    Posted 2 years ago #

    I didn't get it :-(
    You mean to insert the code in the qtranslate_javascript.php
    at the end before the last } closes?

    If I do that I am getting an error message and neither the website nor the dashboard is shown. Did I something wrong???

  7. fyllhund
    Member
    Posted 2 years ago #

    this is how your qtranslate_javascript.php should look like at the end

    function cbnet_tinymce_config( $init ) {
    
    		// Don't remove line breaks
    		$init['remove_linebreaks'] = false;
    		// Convert newline characters to BR tags
    		$init['convert_newlines_to_brs'] = true;
    		// Do not remove redundant BR tags
    		$init['remove_redundant_brs'] = false;
    
    		// Pass $init back to WordPress
    		return $init;
    	}
    	add_filter('tiny_mce_before_init', 'cbnet_tinymce_config');
    
    }
    
    ?>

    So if you're getting that error you probably did something wrong

  8. coldert
    Member
    Posted 2 years ago #

    About that cbnet_tinymce_config solution. Is it really qtranslate_javascript.php you should edit? I put that code in my themes function.php, and that worked perfectly.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags