WordPress.org

Ready to get started?Download WordPress

Forums

Having problems with previous/next page (5 posts)

  1. theoak1ey
    Member
    Posted 2 years ago #

    Hi, I was looking round my site today making sure everything was up ok and when I went to click on the "next" page as the current page had reached the maximum post I had allowed (10) it come up with "404 Error".
    I think the error is that the page thinks its the 1st page which is why the page only shows a "next" button, when it is actually the last page so it should say "previous".
    So does anyone know what I have to do to set it right. I am using the Mystique theme if that makes a difference.

    My site is http://www.allthatzgaming.com/home
    if you scroll down to the bottom you will see the "next" button.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. theoak1ey
    Member
    Posted 2 years ago #

    None of thos fixed the problem however it did change the problem I was having with the homepage showing every post I had, instead of just 10. Thanks to that fixing itself it now has the "next" page button as well and that works fine so i'm wondering if its a category specific problem as the home button in the nav bar is a category but my home page is set to my latest posts. I also added all the post to another category and the 404 problem comes up.
    If you click the link below and scroll to the bottom and click "next" it works fine.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    The home button on your custom menu nav bar is clearly pointing to http://www.allthatzgaming.com/home and not http://www.allthatzgaming.com/ so I suggest you try amending that via Appearance-> Menus.

  5. theoak1ey
    Member
    Posted 2 years ago #

    Thanks esmi that worked a treat

Topic Closed

This topic has been closed to new replies.

About this Topic