WordPress.org

Ready to get started?Download WordPress

Forums

Having problems with customizing permalink structure (10 posts)

  1. mbm
    Member
    Posted 7 years ago #

    Hello everyone I have been using wordpress for a few months now this is the first problem I have encountered where I felt the need for assistance.

    When I try to customize my permalink structure using any of the options offered in the admin section my whole site goes 404 error :(

    What I really need to do is change the permalink structure to fit this �/%category%/%postname%/�

    I switched to the default theme thinking it may be my theme for some funny reason and when I tru to change the permalink structure I still get the same error...

    Can someone ppplllleeease help me I need to get this problem solved!

    Thanks a lot

    the url of the blog im talking about is www dot halo dot info

  2. richarduk
    Member
    Posted 7 years ago #

    http://wordpress.org/support/topic/108996?replies=1
    Is this relevant?

    If not, are you really using question marks before and after the structure tags or is that just a glitch in pasting the code? Or pressing shift when typing in the slashes?

    Using %category%

    %category% does not work correctly with some implementations of mod_rewrite in Apache versions prior to 2. If you are using Apache 1 and experience problems with using %category%, either do not use %category% in your permalink structure, or refer to Schlueterica's plugin (http://isaacschlueter.com/plugins/i-made/lucky-13-rewrite/).

  3. mbm
    Member
    Posted 7 years ago #

    richarduk thank you for your reply

    Its not just from using category basically when i try every option allowed prior to customize and click update my whole site goes blank.. hmmm this is wierd :[

  4. ghanshyamgadhiya
    Member
    Posted 7 years ago #

    Just write your permalink structure like this

    index.php/%category%/%postname%/
    instead of
    �/%category%/%postname%/�

    It must work. :)

  5. mbm
    Member
    Posted 7 years ago #

    thanks everybody but whenever i try to update my link structure my site still goes completley blank. Ive been stuck on this for a week somone please help !? :P

  6. richarduk
    Member
    Posted 7 years ago #

    No error messages from php?

    Blank index page?

    I use this: /index.php/%postname%

    Note that there is no trailing slash at the end of it.

    To figure out what's going on, start at the beginning - try a few variations on the permalink structure and see if any of them work.

  7. ryansebiz
    Member
    Posted 6 years ago #

    I'm having the same problem. When I try any of the default Customize Permalink Structure common options, save, refresh my site and click on a post I get this error in Firefox:

    The system cannot find the file specified.

    I get this error in IE7:

    The webpage cannot be found

    I have created a blank .htaccess file and placed it in the root of my site, as suggested here: http://codex.wordpress.org/Using_Permalinks

    Also the Lucky 13 plugin is clearly marked Not For WordPress 2.0. Since I'm using 2.2, any ideas to get this working?

  8. audible
    Member
    Posted 6 years ago #

    I am having the same issue after moving my wordpress to a new server. Custom permalink structure has worked for me in the past with the old server but after moving, all the links are broken unless I go to default permalink. Now all my URLs are not search engine friendly. I'm using WP 2.2, please help.

  9. solidariti
    Member
    Posted 6 years ago #

    I had the same problem, it took me one week of searching through these forums, if you are getting the 403 error or 404 error take a look at this page it helped me straight away.

    http://www.htaccesselite.com/htaccess/wordpress-permalink-403-error-vt171.html

    My problem was 403 error so I did what it recommended which was to insert this in my .htaccess file Options +SymLinksIfOwnerMatch above <IfModule mod_rewrite.c> and above this # BEGIN WordPress so it doesn't get over written and my pretty permalinks /%category%/%postname%/%post_id% which resolve to http://test.dappastyles.com/about/ for my pages worked.

    Hope this helps.

  10. donderhaas
    Member
    Posted 6 years ago #

    I had the same problem, all I had to do was go to the file on the server htaccess and change the file permissions so that wordpress can update it. Now everything is looking - "Pretty"

Topic Closed

This topic has been closed to new replies.

About this Topic