WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Having problems moving my site (4 posts)

  1. mcederholm
    Member
    Posted 4 years ago #

    Hi

    I am trying to move two of my wordpress installations from two different accounts to another my main account that already have a third WP installation.
    I'm trying to move my second site now to try it out.
    The sites are:

    Mandalay.se (main account where all three are going)
    Varande.com
    Teddybjorn.se

    They are all on the same server but on different domains. They also use different MySQL databases. Since they are all on different sites, they are now all three in different databases all with the same name "Wrdpr1" so I have to put the second and third site in new databases.

    So this is what I have done:

    1. I have followed the instructions and exported the databases from old site
    2. Downloaded all the files locally
    3. Created a database named mandalay_varande
    4. Uploaded all the files into the folder mandalay/varande/
    5. Imported the sql-backup with phpmyadmin into the new database "mandalay_varande"
    6. Changed the "site-url" and "home"-tables in the wp_options table to http://mandalay.se/varande
    7. Edited wp-config.php with the new database name, user and password.

    My plan is to redirect the domain varande.com to the new folder when it is done and I know everything works...
    When I go to the new site at mandalay.se/varande/ all I get is this: "Error establishing a database connection".

    What am I doing wrong here? Have I missed something crucial?

  2. ryans149
    Member
    Posted 4 years ago #

    wp-config.php on new domain (Mandalay.se), check this file. Is your database details correct ?

  3. ryans149
    Member
    Posted 4 years ago #

    I can give you an advise:

    Export the posts from wordpress in XML format and then import them one by one to your new installation..

  4. mcederholm
    Member
    Posted 4 years ago #

    This is slightly embaressing!
    The wp-config.php I edited and uploaded three times was put in the root folder instead of the wordpress folder!

    Thanks for the help!

    //Matthew

Topic Closed

This topic has been closed to new replies.

About this Topic