WordPress.org

Ready to get started?Download WordPress

Forums

Having difficulty (9 posts)

  1. mollykat
    Member
    Posted 7 years ago #

    I have just acquired wordpress through my webhost, hostgator.

    I am having some problems...

    I was trying to change the theme/template of my blog cannot seem to get it right. the theme i wish to work with is "juicy", i download said theme and then extracted the files, i then use cuteftp to upload the files onto hostgator, however, it says (in wordpress) that i am missing the template???

    I don't know what to do, all I want is a template to modify to suit my needs but i am having problems...

    I also have weird things happening when i access my blog through hostgator as opposed to just signing in at wordpress...almost like i have 2 accounts...possible?

    also, how do you get to the admin panel????

    any help is and will be appreciated

    thank you

    sandra

  2. vkaryl
    Member
    Posted 7 years ago #

    Make sure that you have only one folder named juicy, with inside it an images folder, the theme's style.css file, and the theme *.php files. Sometimes extraction programs uncompress into multiple layers of theme folders.

  3. moshu
    Member
    Posted 7 years ago #

    1. Any new theme you should not upload in generally to "hostgator" - but exactly under the wp-content/themes/ directory, each theme into its own folder!
    2. Every host offers a kind of "site administration" panel (interface). That has NOTHING to do with your WordPress blog admin panel - they are two different animals :)
    3. Which admin panel?
    For your blog: yourdomain.com/wp-admin

  4. mollykat
    Member
    Posted 7 years ago #

    moshu,

    thank you for your post, here is another problem...

    when i type http://my-domain-name.com/wp-admin i receive a 404 error!!!!

    Also, i did upload the template into the file wp-content/themes/test...a seperate directory from the other 2 themes available by default...all individual files seem to be intact...ie; sidebar, header, images, css.style etc. (you get the picture) which i have uploaded to my wordpress blog located at hostgator...

    Can anyone please offer a suggestion as to how i am going to sort this all out?

    why can i not access my admin panels simply by typing the above url?

    Thanks, again

    Sandra

  5. moshu
    Member
    Posted 7 years ago #

    1. Maybe because that's NOT the right address!
    Your blog is NOT at the root, but in a subfolder called "blog" > http://www.savvy-server.com/blog/
    so the admin is at http://www.savvy-server.com/blog/wp-admin

    2. If a theme is called "moshu" don't put it in a folder called "test" :) - theme folder names ARE important for WP to match the stylesheet and index template. (and a clarification is due: themes are uploaded, not templates! A theme can have zillion template files... to make sure we are on the same page)

  6. mollykat
    Member
    Posted 7 years ago #

    Thank you "moshu".

    As it turns out I have done quite a few things incorrectly...

    Thank you for your advice, i am now in the process of sorting things out (wrong name of the database in config file!)...

    Also, I have yet to learn the proper terms ie: upload, download, script, theme, templates...but rest assured I am working on it, as soon as I learn WordPress I will be talking as if i were a professional!

    thanks again

    Sandra

  7. moshu
    Member
    Posted 7 years ago #

    Just for the record: in this moment the DB name in the wp-config MUST be correct because I can see your blog! Better don't touch it :)

  8. mollykat
    Member
    Posted 7 years ago #

    Moshu,

    remember that "simpsons" episode...where all homer can hear is blah, blah, blah...?

    "DB name, wp-config file??? MUST...you can see my blog???"

    OMG, i am in so much trouble!!

    Who has the coles notes version on all Internet lingo...?

    sounds like a great ebook!!!!

    Watch for my name...I am about to start editting!

    Doh!

    Sandra

  9. moshu
    Member
    Posted 7 years ago #

    Your wrote:
    i am now in the process of sorting things out (wrong name of the database in config file!)...

    Sorry, for using DB = for database :)
    And all I wanted to say: your database name is correct, otherwise I wouldn't be able to see your blog.
    [take in account I am the non-native English speaker mod here :)]

Topic Closed

This topic has been closed to new replies.

About this Topic