WordPress.org

Ready to get started?Download WordPress

Forums

Have WordPress Automatically Write To .htaccess file (4 posts)

  1. bdbdkd
    Member
    Posted 8 years ago #

    I'm not very tech savy, so bear with me.

    I just downloaded WP version 1.5.2

    I made the correct updates to Permalinks and the links appear fine in my browser bar. (No more WP default codes).

    However, I downloaded the FeedBurner plugin and have been having a lot of problems. People keep telling me that I need to have WP write automatically to my .htaccess file.

    I can't find anywhere to turn automatic writing on or off.

    The permalinks seem to work fine, but when I look at my .htaccess file in my web host control panel it is blank.

    HELP PLEASE :)

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    That means that the file permissions for the .htaccess file should be 666

    Login to your blog
    Click Manage, then Files
    Look on the right column for .htaccess
    Click it
    Do not edit in the box, just look under it.
    If it has an 'Update' button, you have nothing to worry about.
    If it says "If this file was writable you could edit it." then you need to change the permissions.

    Do that then let us know ?

  3. Your server could also be blocking WordPress' ability to alter the .htaccess file, but having incorrect file permissions (IOW, not having .htaccess' file permissions set at 666) is usually the problem. More info: http://codex.wordpress.org/Using_Permalinks#Fixing_.28.htaccess.29_Generation_Issues

  4. bdbdkd
    Member
    Posted 8 years ago #

    Thanks for the quick reply.

    I followed your instructions.

    When I go to Manage then Files, it does have a Update button. :)

    However, the edit box is totally blank as if there is nothing in the .htaccess file. Also, at the very top of the page it says... Warning: fread (): Length parameter must be greater than 0. in /home/efsaffil/public_html/efsinternet/blog/wp-admin/templates.php on line 73.

    I went into my ThirdSphere control panel and saw I have 3 .htaccess files. One in my public_html directory, one in my efsinternet sub directory and one in my efsinternet/blog directory. (efsinternet is a subdomain parked on my main domain of efsaffiliatemarketing.com)

    I changed all three .htaccess files to 0666.

    But...
    Unfortunately, I still have the same problem with feedburner. When I setup a feed, everything is fine. Then a day or two later, it can't find the feed address it assigned. When I type the feed address into my browser, it shows the whole blog page instead of the feed page.
    :(

    Bob

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags