WordPress.org

Ready to get started?Download WordPress

Forums

FeedWordPress
Has FeedWordPress been discontinued?? (23 posts)

  1. paravia
    Member
    Posted 1 year ago #

    I wonder if this plugin has been discontinued since the last update was almost one year ago, I keep getting errors on feeds that worked before WP 3.4 ('The data could not be converted to UTF-8' mostly), and it crashes with PHP 5.4 (white screen of death).

    http://wordpress.org/extend/plugins/feedwordpress/

  2. timmmmyboy
    Member
    Posted 1 year ago #

    I can tell you we still use it extensively (the latest version of both FWP and WP together) at our university and haven't had issues. We've talked to the developer about custom development and I know he still continues work on it (though I don't know how active he is here as opposed to his own site)

  3. ppehrson
    Member
    Posted 1 year ago #

    I guess then Timmmmyboy, then your University requirements are MUCH lower than the standards we require in Denmark. As the plugin is filled with flaws etc, it would never been accepted on production machines here. :)

  4. paravia
    Member
    Posted 1 year ago #

    I have it installed on at least 200 sites, if it wasn't for the UTF-8 error, it would still be quite usable. In fact, I still (have to) use it since there is no easy alternative.

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    @ppehrson: Then I suggest you try looking for another plugin. And please stop posting in multiple topics relating to this plugin.

  6. ppehrson
    Member
    Posted 1 year ago #

    The UTF-8 error doesn't seem to show for me. Are you sure your server serves in UTF-8, your db is UTF-8 as well as everything else you can set?

    There certainly IS an easy alternative, but it costs a bit.

  7. paravia
    Member
    Posted 1 year ago #

    the UTF-8 error shows on my local MAMP as well as different hostings, and it all started after WP3.4x.
    What's the easy alternative, autoblogged? eww

  8. radgeek
    Member
    Plugin Author

    Posted 1 year ago #

    Hey y'all,

    Just as a quick note: FeedWordPress has not been discontinued. I regret that it's been so long since the last public update; things have been held up by a number of competing claims on my time. But the current state of development can be seen at http://github.com/radgeek/ , and I plan on issuing a new release tested against all versions up to WP 3.4.x within the upcoming month.

    If you're encountering compatibility problems related to WP 3.4.x, please don't hesitate to send me an e-mail through http://radgeek.com/contact with "WP 3.4 compatibility" in the subject line, and as much information as possible about the specific problem you're encountering, the URL(s) of the feed or feeds you're encountering the problem on (if relevant), etc. I am working on tests for the new version as we speak, so I should be able to put any reports on the top of the stack very quickly.

  9. paravia
    Member
    Posted 1 year ago #

    That's terrific news Radgeek (and thanks for the awesome plugin!). As far I am concerned, many perfect feeds _sometimes_ give these errors: "The data could not be converted to UTF-8. You MUST have either the iconv or mbstring extension installed." (but of course I have them),
    and this error "This XML document is invalid, likely due to invalid characters. XML error: SYSTEM or PUBLIC, the URI is missing at line 1, column 53"
    but if I try again after a few days, they may work (or not). So it is intermittent.
    My scenario is your plugin along with
    Add Attribution for FeedWordPress
    FeedWordPress Duplicate Post Filter
    FWP+: Limit posts by date
    YD Feedwordpress content filter
    and WP 3.4.1

    The second problem is that with MAMP and PHP 5.4, FeedWordPress gives the white screen of death, but this is not so important.

    Thanks!

  10. amandafrench
    Member
    Posted 1 year ago #

    For what it's worth, radgeek, I've got the same problem as paravia (and a very similar setup, plugins and all). And ditto on the awesome plugin -- given how powerful it is, I think it's amazingly bug-free in general. Pay no attention to ppehrson.

  11. anna.mule
    Member
    Posted 1 year ago #

    Can any of you all share some links of this plugin in action? Thanks!

  12. timmmmyboy
    Member
    Posted 1 year ago #

    The largest site we run it on is ds106 which is about 500 blogs feeding in to one main site. We also have some smaller course sites that use it at UMW, an example of that being this page of a digital history course.

  13. paravia
    Member
    Posted 1 year ago #

    Check out these automated city portals all made using this plugin.

  14. emeraldryan
    Member
    Posted 1 year ago #

    I also started getting the error message below in the last few days:

    The data could not be converted to UTF-8. You MUST have either the iconv or mbstring extension installed.

    My web host increased the PHP memory limit from 32MB to 96MB and that seems to have fixed the problem.

  15. hash73
    Member
    Posted 1 year ago #

    Hi,

    I'm running PHP 5.5 and now have this issue:

    Fatal error: Call-time pass-by-reference has been removed; If you would like to pass argument by reference, modify the declaration of do_action(). in /home/jazzclub/public_html/wp-content/plugins/feedwordpress/admin-ui.php on line 53

    Any help would be appreciated as the site is down.

    thanks

  16. afffff
    Member
    Posted 1 year ago #

    I'm having the same problem while trying to import the feed from another wordpress blog, a password protected one :(

  17. Bozz
    Member
    Posted 1 year ago #

    FWIW, I believe the issue is with using PHP 5.4+

    I'm running 5.3 and the plugin is work as expected for me.

  18. ioian
    Member
    Posted 1 year ago #

    @radgeek - Your plugin is awesome and there isn't really anything that compares to what it does, but the problems with your versioning not keeping up with WordPress is an ongoing issue that forces people to use an older version of WordPress past it's used by date.

    I for one think that you should offer a cut-down free version and an affordable paid plugin with the full set of features. I am sure that from the popularity that you would easily obtain the funds to support regular ongoing development and support...

    I don't mind paying for code that I know is updated and can get support when something does go wrong.

  19. ronajon
    Member
    Posted 1 year ago #

    the call-time pass-by-reference errors can easily be fixed for php5.4:

    file syndicatelink.class.php line 328 change &$this to $this
    file admin-ui.php line 53 &$post and &$this to &post and &this
    file admin-ui.php line 84 &$post and &$this to &post and &this

    hope this helpes

  20. debbrancheau
    Member
    Posted 1 year ago #

    I know I'm not supposed to post off topic but I just want to say that, yes, I've had a couple issues with this plugin but there is no other FREE plugin like it. When someone takes the time to put together a powerful plugin like this and offer it to the community for FREE, I think that's friggin' fantastic and I'm not going to complain.

    Thanks radgeek for an awesome plugin that I use ALL THE TIME! I'm soooooo glad to here you're still helping us by continuing to make your plugin better!

  21. radgeek
    Member
    Plugin Author

    Posted 1 year ago #

    Hey y'all,

    So, for reference, a new release is out today with compatibility fixes for WordPress 3.4.x-3.5, and PHP 5.4. This was pushed out quickly in order to take care of an issue that was making the admin UI unusable for some users with WordPress 3.5; so of course it is possible that there are other issues remaining to be cleared out. But take a look, let me know if it solves your outstanding problems, and if not, what issues you are still encountering. The new release is 2012.1212, available either from github or from:

    http://wordpress.org/extend/plugins/feedwordpress/

    Thanks,
    -C

  22. kbunt
    Member
    Posted 1 year ago #

    Ditto to ioian's and debbrancheau's comments. Thanks radgeek you are awesome!

  23. shabicht
    Member
    Posted 1 year ago #

    For those of you still getting the error "The data could not be converted to UTF-8" I found a fix for the issue today. The problem seems to be with the opensource code simplepie. I downloaded the latest version here:
    http://dev.simplepie.org/

    I then replaced my file /wp-includes/class-simplepie.php with the newer version and the issue went away. (I'm be monitoring over the next day to make sure).

    I would guess that the issue was intermittent because the newer posts in a feed caused the post causing the issue to get pushed out of the feed over time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.