WordPress.org

Ready to get started?Download WordPress

Forums

harsh login problems with different accounts on sa (13 posts)

  1. huphtur
    Member
    Posted 10 years ago #

    i seem to have run into a weird problem.
    once i have logged into wp with a certain l/p i am unable to login with a different l/p on the same computer. it only allows me to login with the first l/p used.
    even after i do a proper logout, it does not allow me to login with a different l/p
    i have tried deleting my cookies, which did not seem to help.
    anybody has an idea why this could happen?

  2. huphtur
    Member
    Posted 10 years ago #

    hrm.. i had to delete the account, and register again.
    thank god i didnt make any posts with that account yet.

  3. southerngal
    Member
    Posted 10 years ago #

    I have this problem as well. I put another blog on the same server, just a different directory. I just did this tonight. I have shut down Zone Alarm and it still does it. I'm not planning on cleaning out my cookies every time I want to blog. Any other suggestions?

  4. otaku42
    Member
    Posted 10 years ago #

    This problem is being worked on by the developers, as far as I know. Please be patient.

  5. Dougal Campbell
    Member
    Posted 10 years ago #

    huphtur, are you trying to login to two separate WP installations? If so, that problem has been fixed in CVS.
    If you're having trouble switching profiles within a *single* instance of WP, that would be odd. I just tested logging out of one profile, logging in as another, and then back again, and it all worked as it should. So if that's the problem, it might be helpful to know what browser and platform you use.

  6. huphtur
    Member
    Posted 10 years ago #

    dougal: i was trying to login on the same weblog with different accounts. I tried it with 2 browsers.
    when i try it on Firebird, it sometimes goes straight to the post/edit screen without asking me for a l/p (i did not tell firebird to remember my l/p). when i click logout, it goes back to post/edit.
    then with IE i had that problem of not being able to login with another account after i logged in with one first. when i press logout it does go to the login screen again, but does not let me login with the other account.

  7. southerngal
    Member
    Posted 10 years ago #

    I am using IE 6 and since my cookies are set for my main blog, I cannot log in using IE for the second blog. I just have to use a different browser or clean out my cookies each time. That's not happening though! I applied the 2 patches for password and settings and it isn't fixed. I reloaded the IE and still not working. Shows me the "Error you have a wrong password" screen. Which in past experiences with b2 and wp means that it's holding the cookie for one blog, but not the other.
    Any help would be great! I don't mind using 2 browsers, but, it's a pain. :)

  8. southerngal
    Member
    Posted 10 years ago #

    Gettting TONS of errors. Here's one from my comments after I posted it:
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 121
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 122
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 123
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 125
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 126
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 127
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 128
    Warning: Cannot modify header information - headers already sent by (output started at /home/florida/public_html/b2-include/b2template.functions.php:1582) in /home/florida/public_html/b2comments.post.php on line 133
    I should have left it alone, but obviously I wrote down and backed up all my files. When I applied the CVS patches to both directories, I received a lot of errors. I have to now uninstall WP and reinstall a fresh copy. That's a real pain. One of my friends couldn't get into the passworded post so I thought it was cookies. Guess I was wrong.

  9. southerngal
    Member
    Posted 10 years ago #

    I solved the entire problem by deleting the second blog and then reinstalling it using Opera. It's the only browser out of Mozilla, IE 6 and Opera that will let me log in to the second blog. It will not let me log into the first blog. I have to use 2 separate browsers to get to 2 blogs.
    When a new release is developed, please address this! Thanks! :)

  10. Dougal Campbell
    Member
    Posted 10 years ago #

    huphtur: weird. Using Moz or IE6 (Windows) I don't have a problem like that. I assume you've tried wiping out your cookies. You could try the CVS code and see if it makes a difference for you.
    southerngal: how did you patch your files? Did you use a CVS program to fetch the code, or did you download via the SourceForge WebCVS interface, or what? I have the current CVS code running on my server just fine, so I'm trying to figure out why it would be giving you all those errors.

  11. southerngal
    Member
    Posted 10 years ago #

    I went to the CVS and downloaded each one, pasted each one in each blog. Messed it up badly. Did I do it correctly?

  12. huphtur
    Member
    Posted 10 years ago #

    yeah, i dont understand how this CVS works as well.
    went to the page, looks rather confusing.
    why are cookies in effect for login if i may ask.

  13. southerngal
    Member
    Posted 10 years ago #

    They shouldn't be effected. I really hope this will be addressed in the next release. It's a pain to have 2 browsers open to post to 2 different blogs. What if I had 3 or more blogs? There are only so many things I will do to blog, erasing all my cookies each time I want to blog, isn't one of them.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.