WordPress.org

Ready to get started?Download WordPress

Forums

Hacked? Site downloads .rar/.gz file (8 posts)

  1. wilhelminawang
    Member
    Posted 4 years ago #

    Hi there,

    For the past couple of days, my website (http://heartbreaknympho.com) has been automatically downloading a file instead of opening - a .rar file, .gz file or just a file with my URL as its name, depending on the browser. The only browser it seems to work in is Mozilla Firefox. I'm wondering if I've gotten hacked somehow, and how I can resolve this? I'm going to try updating to the newest version of WordPress but I doubt that will work...

    Thanks,
    ~ Wil

  2. Mark / t31os
    Moderator
    Posted 4 years ago #

    Could a problem with the server interpreting mime types...

    If you open said file that downloads though, you'll see the output of your WordPress generated page..

    Did notice this at the bottom of that file though..

    <!-- Dynamic page generated in 1.643 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2009-12-29 23:29:47 -->
    <!-- Compression = gzip -->

    Perhaps there's a problem with the caching, could you try removing super cache to see if that brings the site back to life?

    Quick way to test if files work normally would be to drop a test file into the root, test.php or something ...

    <?php
    echo 'This is my test page';
    ?>

    Then fire up the new page..

    yoursite.com/test.php

    If it loads, then your site is reading the document mime types fine, and i'd bet it's a plugin / caching issue.

    Of course neither of my suggestions may help at all... but you never know... ;) ..

  3. wilhelminawang
    Member
    Posted 4 years ago #

    Thanks a ton. I tried deactivating supercache, didn't seem to work, and I got this weird message when I deactivated it:

    Warning: unlink(/var/www/heartbreaknympho.com/public/wp-content/wp-cache-config.php) [function.unlink]: Permission denied in /var/www/heartbreaknympho.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 97

    Warning: unlink(/var/www/heartbreaknympho.com/public/wp-content/advanced-cache.php) [function.unlink]: Permission denied in /var/www/heartbreaknympho.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 97

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/heartbreaknympho.com/public/wp-content/plugins/wp-super-cache/wp-cache.php:97) in /var/www/heartbreaknympho.com/public/wp-includes/pluggable.php on line 865

  4. wilhelminawang
    Member
    Posted 4 years ago #

    Also, deleted the plugin and that didn't work either... sigh. I'll try the other things you suggested too

  5. edesouza
    Member
    Posted 4 years ago #

    Hi - I am having a similar issue with my site. Instead of the home page coming up... I get a download.gz file. Found that re-publishing a sticky post that I had on the homepage fixed the issue temporarily. But it seems to be recurring. Any suggestions or thoughts on what it might be.

    I have disables Super Cache as well as a XML site generator plugin which I though may have been causing this. But it does not appear to have fixed the issue permanently.

  6. I've been running fine with WP Super Cache for a year and suddenly one of my sites is having this error, but it's NOT consistent!

    Firefox seems fine, one of my friends says that IE and Chrome are fine, but another says only IE is okay. I can't visit on Chrome OR IE.

  7. Donncha O Caoimh
    Member
    Posted 4 years ago #

    This happens randomly, I don't know why as I've debugged it extensively. Switch to half-on mode and it shouldn't happen. Switch off compression and it definitely won't happen.

  8. Per my other post it got even weirder!

    People were getting gzipped comments in the page source an hour after I'd turned off compression, and about 10 minutes after I'd uninstalled WP Super Cache.

    Somewhere my server just went HOOOOOOORK.

    It's fine now and it's insanely annoying. *sigh* Thanks for replying. I was pretty sure it wasn't your plugin, as the other three WP blogs on the server use it and they were fine.

Topic Closed

This topic has been closed to new replies.

About this Topic