WordPress.org

Ready to get started?Download WordPress

Forums

Grunion ignores my extra fields (2 posts)

  1. sempervirent
    Member
    Posted 3 years ago #

    The topic title says it all. I set up a form that looks like this:

    [contact-form subject="Website Contact" to="xxxxxxxx@gmail.com"]
    [contact-field label="Name" type="name" required="true" /]
    [contact-field label="Email Address" type="email" required="true" /]
    [contact-field label="Phone Number" type="text" /]
    [contact-field label="School/Company/Organization" type="text" /]
    [contact-field label="Message" type="textarea" /]
    [contact-field label="I would use your product in:" type="radio" options="School District,Afterschool Program,Library Program,Museum or other Cultural Institution,Other" /]
    [/contact-form]

    All the form elements appear as expected on the page.

    But when I send the message, I only get the Name, Email, Website, and Message fields (the default set) in the email. A dead giveaway is that "Website" is not even included in the shortcode above but it shows up in the email that I receive.

    Any ideas?

  2. sempervirent
    Member
    Posted 3 years ago #

    Still haven't made any progress on this, and would appreciate some advice. Next step is to try out something else but I would like to be able to use the form builder that's so nicely integrated with the Page/Post editor:

    http://www.ditii.com/2010/12/21/wordpress-com-contact-form-upgrades-and-grunion-contact-form-for-wordpress-plugin-released/

Topic Closed

This topic has been closed to new replies.

About this Topic