WordPress.org

Ready to get started?Download WordPress

Forums

Imaguard
[resolved] Great plugin -- but I can't get it to work! (5 posts)

  1. altfgcom
    Member
    Posted 1 year ago #

    Hello,

    First of all, great plugin from what I've read in this forum. I went through every single thread. Your patience and readiness to respond to those with issues is much appreciated, especially when sometimes people are both demanding and less-than-courteous...

    Now, unfortunately, I'm having trouble getting Imaguard to work for our site.

    Checklist:
    The site's server runs PHP 5.2. DG Library enabled.
    WP Permalinks enabled. That's how it's been for years.
    WP SuperCache cache deleted. Imaguard plugin deactivated and then reactived.
    Checked Google Images search on Chrome, both signed in to Google & anonymous browsing.

    Unfortunately, neither Imaguard's "redirect" nor the "show darkened image" option worked for us.

    Possible causes for the problem (now it gets a little complicated):

    Imaguard modifies the site's .htaccess file in the "blog" (WP) folder. The site, however, has another .htaccess file in its root folder, "above" WP.

    We had an anti-hotlinking protection code pasted there. With or without Imaguard activated, that code works. (Blurry images; but if the browsing individual has signed in to Google, the full size, high-res. image is shown -- much to our outrage).

    If our anti-hotlinking code is removed and Imaguard is left alone, *nothing* works. In other words, the images on Google Images are loaded full size, high-res. for *everyone*.

    We also tried removing our own anti-hotlinking code and pasting the Iamguard .htaccess code on the site's topmost .htaccess file. That didn't work either. Hotlinked images were loaded normally.

    Important: Our images are NOT wp-upload images. They're found in a different folder, uploaded via regular FTP, *outside* the WP folder.

    Could that be the issue? If so, is there a workaround?

    I'd like to send you both .htaccess files and links to the site so you can see for yourself what's going on, but I'll wait for your go-ahead before I do so.

    Thank you.
    P.S. Regarding comments found elsewhere in this Imaguard forum: My understanding is that Google Images sends a blank referrer when uploading your images. We currently allow blank referrers, which helps to explain why our high-res. images are loaded to those who have signed in to Google. Now, we did try blocking blank referrers and that worked in preventing high-res. images from loading to *anyone*. The glitch: Google wouldn't index our new images and several older ones were dropped from their index. It's infuriating, maddening, outrageous -- but that's how their system works now. (Until the inevitable class-action lawsuit...)

    http://wordpress.org/extend/plugins/imaguard/

  2. imaguard
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there!

    We'll try to sort it out :)

    Does the imaguard plugin redirect and then the image doesn't show - or doesn't it redirect at all?

  3. altfgcom
    Member
    Posted 1 year ago #

    Hello,

    Thanks for the reply.

    The plugin doesn't redirect at all. Nothing happens. The site's images are fully loaded on Google Images, whether we have the "non-aggressive" or the "aggressive" option checked.
    Should I send you the site's .htaccess files & site info via email?
    Please advise.
    Thank you.

  4. imaguard
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, please send the htaccess file for the WP root folder and a link to your site on admin@imaguard.com and we'll have a look at it.

  5. imaguard
    Member
    Plugin Author

    Posted 1 year ago #

    Got your email. I noticed from your htaccess file that you've got a cache plugin. This will normally override Imaguard and keep serving cached versions, but a brief look on the (massive) rewrite code seemed to indicate you are excluding your image files, right?

    There is definitely one obvious error in the Imaguard htaccess code:

    RewriteCond %{HTTP_REFERER} !^http://(.+\.)? [NC]

    This is definitely missing an important bit
    RewriteCond %{HTTP_REFERER} !^http://(.+\.)?yoursite\.com [NC]

    I can't off the top of my head say why Imaguard isn't picking up on your WP URL. Which version of WP are you using?

    You can try to fix it by editing the htaccess file manually. But I suspect there will then be a problem with the file structure since you have a permanent redirect from root folder to /blog so at least you would have to change this line in the imaguard index.php file:

    $ir_location = get_bloginfo('url')."/index.php?p=".ir_getpostidbyurl($_GET['img']);

    to

    $ir_location = get_bloginfo('url')."/blog/index.php?p=".ir_getpostidbyurl($_GET['img']);

    and even then I suspect you may have to add a ".." to this line too so it will be

    $ir_location = get_bloginfo('url')."/blog/index.php?p=..".ir_getpostidbyurl($_GET['img']);

    to compensate for the fact that your images are hosted outside your WP folder.

    I am able to confirm that Imaguard itself is working as I can see watermarked images by going to

    http://www.yoursite.com/blog/show-image/?img=../Yourphotofolder/photo-actors-x/x-xson-x-x-x-x-x-x.jpg

    Sorry for the x's but I didn't want to identify your site accidentally. It's just the image file name.

    You haven't added a watermark text yet, but it shows the Powered by Imaguard optional text for now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic