WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms Creating Untitled_ Draft Posts in wp-admin (4 posts)

  1. uabassguy
    Member
    Posted 8 months ago #

    I've been searching online for hours so please forgive me if this turns out to be a duplicate.

    Problem: When a new user registers using the form, a Draft post is automatically created. I want to prevent the posts from being created.

    I am aware that Post Fields exist for this reason, however I don't see any options in any form fields for Post creation, basically it should not be creating posts at all.

    The posts appear as blank with Untitled_# (incremental number) as title, and no content.

    I've found code to disable post creation here: http://www.gravityhelp.com/documentation/page/Gform_disable_post_creation

    However I don't feel like modifying the Gravity Forms files would be a good idea, as upgrading the plugin would overwrite the change.

    Where can I add this code in the template to disable post creation on submit, or if an option is available in the CMS to disable it that I haven't seen? I've gone through each form element as I mentioned earlier and I don't see anything about post creation, so it's hard to tell which element is at fault.

    I've been at this for hours for something that should be a relatively simple fix, so any help is greatly appreciated.

  2. germundal
    Member
    Posted 8 months ago #

    So you are using Post Fields in your form? Why?

  3. uabassguy
    Member
    Posted 8 months ago #

    None of them say Post Field most of them say Custom or Name/Email/etc. Which is why this is confusing why WP would behave this way.

  4. zerodegreeburn
    Member
    Posted 4 months ago #

    I've been investigating this issue for a client and it's definitely to do with gravity forms. Adding that code to your theme's functions.php file will not interfere with Gravity Forms updates in any way (you are not editing any of the plugins files) so you can safely add it if you like :)

    EDIT: Oh actually I see you don't add it to functions.php you do have to edit the plugin... I will update once I find out where the actual setting has been set, it must be on one of the forms somewhere.

Reply

You must log in to post.

About this Topic