WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] gravatars from skippy does't work (12 posts)

  1. piotr82
    Member
    Posted 8 years ago #

    Hey there :)

    Please helpme with that, i have a gravatars from skippy but they doesn't work.
    See here for details. I can shouw you my php files and tell you what is what.

    http://oceanic.wsisiz.edu.pl/~slabosz/wordpress/?p=664

  2. Have you contacted Skippy?

  3. piotr82
    Member
    Posted 8 years ago #

    Yes i wrote an email to him yesterday but no reply till now.

  4. You mean it's showing random images rather than people's own gravatars? Just did a couple of test comments to see what's happening.

    Skippy has been around on the forums over the last few days, so he might see this. Otherwise, you might want to contact him directly through the comments on his plugin page:

    http://www.skippy.net/blog/2005/03/24/gravatars/

    In the meantime, can you post the code you are using to insert the Gravatars in your comments.php?

  5. piotr82
    Member
    Posted 8 years ago #

    The code is here : http://oceanic.wsisiz.edu.pl/~slabosz/comments.phpt

    I should tell i was working on this comments.php file alot.
    I was changing the template of comment.
    But i don't know from a start did that gravatar work because i use local images.

  6. skippy
    Member
    Posted 8 years ago #

    What exactly is the problem? It's not clear to me what the problem is. I see gravatar images in the link you provided.

  7. piotr82
    Member
    Posted 8 years ago #

    Yes skippy, but this images are from local files, not the global gravatars.
    They didn't work.

  8. It's showing the random, presumably locally saved, gravatars rather than the commenters' real ones. That's certainly not my gravatar showing there....

  9. skippy
    Member
    Posted 8 years ago #

    The plugin is serving random gravatars because it thinks that the commenters have no gravatars. This could be for a number of reasons.

    piotr82: Your comments.php looks fine. Have you enabled gravatar caching? If so, try turning it off (Options -< Gravatars).

  10. piotr82
    Member
    Posted 8 years ago #

    skippy you are the man :)

    i set cache gravatar to no

    the gravatars is now showing, but no random local gravatars now

    http://oceanic.wsisiz.edu.pl/~slabosz/wordpress/?p=664

  11. skippy
    Member
    Posted 8 years ago #

    The URL being constructed for the random image is incorrect:
    default=http://oceanic.wsisiz.edu.pl/~slabosz/wordpresswp-content/gravatars/random/06.gif

    You need a slash between wordpress and wp-content. Make sure that the "Default Gravatar Image" at Options-<Gravatars starts with a leading slash.

  12. piotr82
    Member
    Posted 8 years ago #

    Great,add that slash at the beginning :
    /wp-content/gravatars/random/

Topic Closed

This topic has been closed to new replies.

About this Topic