WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Gravatars always showing, no matter what option I choose (8 posts)

  1. MTO
    Member
    Posted 4 years ago #

    Gravatars are always on, no matter what option I choose.
    - Mysterious man
    - White
    - Identicons
    - Etc.

    I always see gravatars, it's confusing me.
    The only way to avoid them is disabling avatars, but that's not what I want. I want to enable identicons, but even when enabled, gravatars are always showing.

    I'm lost.
    Any idea what could be going on?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Remember to press CTRL and F5 simultaneously when viewing an updated page/site. Or try emptying your browser cache. This should ensure that your web browser fetches a fresh copy of the page rather than serving up an out-dated copy from your own cache.

  3. MTO
    Member
    Posted 4 years ago #

    Yes, I do that, as well as using multiple browsers/sessions.
    And deleting wp cache after every change...
    But no, that's not it, it's been going on for quite some time (month or so).

    And as far as I can tell, the theme should correctly be calling it through get_avatar
    I'm lost

  4. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

  5. MTO
    Member
    Posted 4 years ago #

    Tried it.
    Deactivated all plugins, deleted cache (wp & self) and nothing... it was still showing gravatars over any option I'd choose.

    In my template, I dont see any reason it should be calling gravatar vs wordpress setting:
    <?php echo get_avatar($comment,$size='48',$default='<path_to_url>' ); ?>

    Upon changing themes, mysteriously some still show gravatars while others identicons (choosen option).
    Weird.

  6. MTO
    Member
    Posted 4 years ago #

    Solved by changing the above code to this:
    <?php echo get_avatar($comment, 48 ); ?>

    Thanks for your help.

  7. bibliotheekgent
    Member
    Posted 4 years ago #

    We deleted last thursday our gravatar at gravatar.com, because we didn't need it any more. But at some places the gravatar is still "on". For instance we see it as an icon in our feed. What can we do about it ?
    http://bibliotheekgent.wordpress.com/

  8. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    I'm thinking those things are cached....dunno how to fix it tho

    I changed my gravatar 2 months ago I'd say.....and it only recently started showing the updated one on this forum, no matter what kind of browser refresh I did

Topic Closed

This topic has been closed to new replies.

About this Topic