WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Gravatar Default Not Resolving (3 posts)

  1. maryjanesfarm
    Member
    Posted 2 years ago #

    I just noticed that the default Gravatar is not actually resolving for our site.
    Example: http://www.raisingjane.org/journal/2668#comments

    Not a big deal, except that in IE (IE 8 and earlier, at least) this means the placeholder with the big ugly "X" gets displayed.
    I think the problem is this: I have set name and email to required for comments (Settings > Discussion > "Other comment settings").
    Therefore, the email field is never blank, and the get_avatar function in /wp-includes/pluggable.php always tries to contact Gravatar for that account's image.
    Not a problem yet, because Gravatar is provided with the info for rendering a default (set to "blank" in the discussion options), and that default image is in place on the webserver.
    If I take the URL from the "src" attribute for the image directly from the page source after the comments have been rendered by the browser, and paste that URL directly into the address bar, Gravatar correctly redirects to my "blank" default image.
    Example: http://1.gravatar.com/avatar/3c74e0be4d3e623fa747e12b1d773c1e?s=40&d=http%3A%2F%2Fwww.raisingjane.org%2Fjournal%2Fwp-includes%2Fimages%2Fblank.gif&r=G

    (Initially "&" in the query string were encoded using "amp;" I had to change each "amp;" to "&" to get Gravatar to resolve properly. Otherwise, I just got Gravatar's logo image. Understandable. So I changed that in the get_avatar function.)

    So, my question, why is the img URL not resolving correctly when on the page in WordPress?

  2. maryjanesfarm
    Member
    Posted 1 year ago #

    OK. How about this?

    The image may not be displaying because some sort of cross-site scripting is not allowed on my server. Therefore, the img URL does work when visited directly via the browser, but won't load when called from the WP site.

    Except, I can call and display images from other sites in a post. Placing the Gravatar URL directly in a post still does not display the default, however. It will hold the space, place background colors, etc. but will not show the blank image selected via the &d= query string (and thus IE still shows the "x" placeholder).

    Well, if I can administer my server via Webmin, what setting should I look for to test this theory out regardless?

  3. maryjanesfarm
    Member
    Posted 1 year ago #

    Alright, well, nevermind.

    It appears to only be an issue w/ IE8 (and probably earlier versions) on Windows XP x64.
    Don't know why still, but not worth worrying about (unless I do start seeing examples on 32-bit XP).

Topic Closed

This topic has been closed to new replies.

About this Topic